summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2023-01-08 15:56:14 +0100
committerMarcin Deranek <marcin.deranek@booking.com>2023-01-08 15:56:14 +0100
commitba2aa91d7401147c69f8478afadd0d0c36b4bf74 (patch)
tree27a89b64b5b6303d5b64908c064ecf9c1632070f /dev-python
parent3918d4b5683afd58d0170f9972854929cd4303cc (diff)
downloadportage-ba2aa91d7401147c69f8478afadd0d0c36b4bf74.tar.gz
portage-ba2aa91d7401147c69f8478afadd0d0c36b4bf74.tar.bz2
portage-ba2aa91d7401147c69f8478afadd0d0c36b4bf74.zip
Initial dev-python/dateparser support
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/dateparser/Manifest3
-rw-r--r--dev-python/dateparser/dateparser-1.1.4.ebuild53
-rw-r--r--dev-python/dateparser/metadata.xml13
3 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/dateparser/Manifest b/dev-python/dateparser/Manifest
new file mode 100644
index 0000000..148c5f3
--- /dev/null
+++ b/dev-python/dateparser/Manifest
@@ -0,0 +1,3 @@
+DIST dateparser-1.1.4.tar.gz 294406 BLAKE2B 5e13a76f1a11dfdb322494a06f288b404149f22481beaf991b0256874aaabb65120fb3e217da5f18d3152cd1786354e2dc8a237591821458be27d5cbac6beac0 SHA512 a20f821dea1ec8e6eb7033de91b1e74777607c4b31286a87e06d85c7278dad3c164ddc88640e0372d9f32eed72a40e28c58bea26a77fdc01c59d2d9fc70bb2d7
+EBUILD dateparser-1.1.4.ebuild 1407 BLAKE2B 920752bd7d55d795e03c19a4d9e6d4e2bdeb6de908b81eee6f3ae681b3b82a091bb118ccb72be325bbbcb4a08e125366ff9a6d8fe8f4671c7d5d1cb15941f4e3 SHA512 6463bc2f5e79945c373ede08766c43f641a0dd2406aaa0a2f69e6d83be591ffe379d28594364d4f473dd39535fb146b96bda6dd57469d0f2a3f2806c73b4f60b
+MISC metadata.xml 460 BLAKE2B 751dd6cd6afe10d63d15ad2e8e7643e802fcbc7c11e7704349f56242fe58c93f2b848dc925795b9556a9a27af5394765e18f23b3f35945ea6242d46852e3a462 SHA512 64c9a6476ea3e0d00addcc55e75058b60d003937765be4248dae3f53ff1e9688521aebd57e8a16dfa3f26a517abd8bc85c49a2b09caeb0dcf3fba238d3a109db
diff --git a/dev-python/dateparser/dateparser-1.1.4.ebuild b/dev-python/dateparser/dateparser-1.1.4.ebuild
new file mode 100644
index 0000000..2f206b9
--- /dev/null
+++ b/dev-python/dateparser/dateparser-1.1.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Date parsing library designed to parse dates from HTML pages"
+HOMEPAGE="https://github.com/scrapinghub/dateparser"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-4"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/regex[${PYTHON_USEDEP}]
+ dev-python/tzlocal[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-libs/fastText[python,${PYTHON_USEDEP}]
+ dev-python/convertdate[${PYTHON_USEDEP}]
+ dev-python/hijri-converter[${PYTHON_USEDEP}]
+ dev-python/langdetect[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_IGNORE=(
+ # tests that require network
+ tests/test_dateparser_data_integrity.py
+)
+
+EPYTEST_DESELECT=(
+ # tests that require network
+ tests/test_language_detect.py::CustomLangDetectParserTest::test_custom_language_detect_fast_text_{0,1}
+)
+
+distutils_enable_tests pytest
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
+
+pkg_postinst() {
+ optfeature "calendars support" "dev-python/hijri-converter dev-python/convertdate"
+ optfeature "fasttext support" "dev-libs/fastText[python]"
+ optfeature "langdetect support" dev-python/langdetect
+}
diff --git a/dev-python/dateparser/metadata.xml b/dev-python/dateparser/metadata.xml
new file mode 100644
index 0000000..78b824c
--- /dev/null
+++ b/dev-python/dateparser/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marcin.deranek@slonko.net</email>
+ <name>Marcin Deranek</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/scrapinghub/dateparser/issues</bugs-to>
+ <remote-id type="github">scrapinghub/dateparser</remote-id>
+ <remote-id type="pypi">dateparser</remote-id>
+ </upstream>
+</pkgmetadata>