summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2022-12-27 22:31:11 +0100
committerMarcin Deranek <marcin.deranek@booking.com>2022-12-27 22:31:11 +0100
commit9d0202a427ce3b6c52b001812a534bbd90c222a1 (patch)
tree0398464d90fcade76245ae660327dc6808a29102 /dev-python
parent3e6a7e18703bd24d05900302c0f5160c93154919 (diff)
downloadportage-9d0202a427ce3b6c52b001812a534bbd90c222a1.tar.gz
portage-9d0202a427ce3b6c52b001812a534bbd90c222a1.tar.bz2
portage-9d0202a427ce3b6c52b001812a534bbd90c222a1.zip
Initial ebuild for dev-python/imap-tools
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/imap-tools/Manifest3
-rw-r--r--dev-python/imap-tools/imap-tools-1.0.0.ebuild32
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/imap-tools/Manifest b/dev-python/imap-tools/Manifest
new file mode 100644
index 0000000..6538599
--- /dev/null
+++ b/dev-python/imap-tools/Manifest
@@ -0,0 +1,3 @@
+DIST imap-tools-1.0.0.gh.tar.gz 248808 BLAKE2B cc265f29ca5978c0b42ce8ef90d8430b54be824c74313289d04f9988bcbd93f8d4891b0f134f53224c62edf535e3b484f1c15000480b1c1b49c600ebe91df1b2 SHA512 bc11009c003f561e9316089f725af035e13650afc7cd54e7e5551d8305aa6af9fe4ee385221c2a5e6105b00686219b4f3c9a69c8199248000f7f60250a17be65
+EBUILD imap-tools-1.0.0.ebuild 791 BLAKE2B ac505f642c9ebbc5538047c47e20a14fb7b66aefb19b3ef1ab9b50ed49734d0cc4537605443cfef2dbe7a46c71072c697d11f53f5bf0514bc607c4314639ace3 SHA512 24ac6e1a9445236c96b112a77c44310945207822e58654e08575d27760e62c78f7aace71145a029d9956a414ea0a2deaeaf9e0a9ddb7f63703e491fc14a5b3ba
+MISC metadata.xml 446 BLAKE2B 03dbf269bc0838c3a73136d1d16282f552ed9d7e1ab2effb2b03acedce9e7275b53f4d80398255de20cd09bd651c589fe92c95a9a19fe0f5a2f4eab89aef9dbb SHA512 8f8c939eeb94838186caafbad2183640c7de99556f1c3e9c1c77fea80f2d368eecd4ba32bfde004f70f5d7f6f76eb83ebe53fb665d09e2c963a5b04d2a031b3f
diff --git a/dev-python/imap-tools/imap-tools-1.0.0.ebuild b/dev-python/imap-tools/imap-tools-1.0.0.ebuild
new file mode 100644
index 0000000..b17a51f
--- /dev/null
+++ b/dev-python/imap-tools/imap-tools-1.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/_}"
+DESCRIPTION="High level lib for work with email by IMAP"
+HOMEPAGE="https://github.com/ikvk/imap_tools"
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/ikvk/imap_tools/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DOCS=( README.rst )
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ # Remove tests requiring credentials for public IMAP servers
+ rm tests/test_{connection,folders,idle,mailbox,message}.py || die
+
+ distutils-r1_python_prepare_all
+}