summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@slonko.net>2024-04-06 21:56:48 +0200
committerMarcin Deranek <marcin.deranek@slonko.net>2024-04-06 21:56:48 +0200
commit8ec16a0512bc753ea4e8bb0c1a16980799d8643d (patch)
tree889adc438cbf3516089bbf8895781b89fe5d55bf /dev-python
parentda983e9777452a1dcc94114cd44c0a7573242872 (diff)
downloadportage-8ec16a0512bc753ea4e8bb0c1a16980799d8643d.tar.gz
portage-8ec16a0512bc753ea4e8bb0c1a16980799d8643d.tar.bz2
portage-8ec16a0512bc753ea4e8bb0c1a16980799d8643d.zip
www-apps/paperless-ngx version bump
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/djangorestframework/Manifest3
-rw-r--r--dev-python/djangorestframework/djangorestframework-3.14.0.ebuild48
-rw-r--r--dev-python/djangorestframework/metadata.xml13
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/djangorestframework/Manifest b/dev-python/djangorestframework/Manifest
new file mode 100644
index 0000000..4cc2bde
--- /dev/null
+++ b/dev-python/djangorestframework/Manifest
@@ -0,0 +1,3 @@
+DIST django-rest-framework-3.14.0.gh.tar.gz 9056443 BLAKE2B 217be67f42207d72d862011a72aecef3e111c1e1dd4b4e090cae6b22dee3fb32e060f7877c498084cf1221eb960b4ca895ef55721f7cabaafe3e36ee152e17a8 SHA512 c1012c656b427e0318b2056e2f984ddc75a5b4e85f375c76fba165ad06e285848eee1bc6dc76c097daec57d780efb2551110199d62ce636a03951aec13ab4013
+EBUILD djangorestframework-3.14.0.ebuild 1307 BLAKE2B 41b40dd945007763cb9c35451b78a2b5eda5263b4cd1a0c95102cc7da2bcca09474f6ebabceb1847f79573936313865c2123b2797cf25a6062b7f48fe75d0e3f SHA512 5ac1a0b7dd41f3cc52d3ad2d356469fecd5f55053930d7ce5df9fb694a3744a14f39404fa36c2bc421bab3498fc01557e9e2d3bf783e54593fd4e1afdf830f14
+MISC metadata.xml 430 BLAKE2B daa4a7fa4c2085627f8a903457f3ebbbbebccba7cf54124bbd0c60b2a05f9bb05a6b303ea6b4b517c406fbfd759803ab3fb95ce45c7c85afa905aadbcb63c905 SHA512 6f15c657338d3cf689da4178b7288d8763fa00b2cc48a5e97e1a669fdcff309ab4ed742183369395ff8292c6627011365b3dcbd44eb77503a98ea47452652fa3
diff --git a/dev-python/djangorestframework/djangorestframework-3.14.0.ebuild b/dev-python/djangorestframework/djangorestframework-3.14.0.ebuild
new file mode 100644
index 0000000..9cd99ed
--- /dev/null
+++ b/dev-python/djangorestframework/djangorestframework-3.14.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=django-rest-framework-${PV}
+DESCRIPTION="Web APIs with django made easy"
+HOMEPAGE="
+ https://www.django-rest-framework.org/
+ https://github.com/encode/django-rest-framework/
+ https://pypi.org/project/djangorestframework/
+"
+SRC_URI="
+ https://github.com/encode/django-rest-framework/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/django-3.0[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ tests/test_description.py::TestViewNamesAndDescriptions::test_markdown
+
+ # require coreapi (but not skipped properly)
+ tests/schemas/test_managementcommand.py::GenerateSchemaTests::test_coreapi_renders_default_schema_with_custom_title_url_and_desc
+ tests/schemas/test_managementcommand.py::GenerateSchemaTests::test_coreapi_renders_openapi_json_schema
+ tests/schemas/test_managementcommand.py::GenerateSchemaTests::test_renders_corejson_schema
+)
diff --git a/dev-python/djangorestframework/metadata.xml b/dev-python/djangorestframework/metadata.xml
new file mode 100644
index 0000000..ff8d78a
--- /dev/null
+++ b/dev-python/djangorestframework/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marcin.deranek@slonko.net</email>
+ <name>Marcin Deranek</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">djangorestframework</remote-id>
+ <remote-id type="github">encode/django-rest-framework</remote-id>
+ </upstream>
+</pkgmetadata>