summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@slonko.net>2023-07-16 21:03:17 +0200
committerMarcin Deranek <marcin.deranek@slonko.net>2023-07-16 21:03:17 +0200
commit7bd31fe1aa83cc564d482b480c02dab16333369e (patch)
tree8237805f39d07636d2e02c506a8698cea86e02bf /dev-python
parent40ef4b8a661b2b6f772e8093f4a54ad0db1d4efc (diff)
downloadportage-7bd31fe1aa83cc564d482b480c02dab16333369e.tar.gz
portage-7bd31fe1aa83cc564d482b480c02dab16333369e.tar.bz2
portage-7bd31fe1aa83cc564d482b480c02dab16333369e.zip
dev-python/nltk version bump
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/nltk/Manifest2
-rw-r--r--dev-python/nltk/nltk-3.8.1.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/nltk/Manifest b/dev-python/nltk/Manifest
index 63e8392..fe70eb7 100644
--- a/dev-python/nltk/Manifest
+++ b/dev-python/nltk/Manifest
@@ -1,3 +1,5 @@
DIST nltk-3.7.gh.tar.gz 2851947 BLAKE2B 4cd4fed9f26de7996bcabbd71d500c072489e79ae0edb29f09577e465227c948efa7130af6975b029e77fb79db015437a9e3311eb28048d02dcc2356441d0908 SHA512 66d79afa59f18f2bf7d086dcb22813c7b92239c05669daa62866dbda06c0ca22367317749cf19db3e41a7bdb405d4f87f72b695aa58fd0669bf36de64f1f9888
+DIST nltk-3.8.1.gh.tar.gz 2867926 BLAKE2B 54de1d3ae7cfe0b71ac0f5a62ed3e81e489fa4d322cd32eb4aa4ef60617eb96767a0f3a92c7e5a16e71836cb0d3a1076ae3598b6bcf0af5925c95e1a0ccf70f8 SHA512 5b13eff5d8e628173f5321c293d896919d369bcd586861a7e09bf6fdca2b09f2580902da98ec647bcf9cdc2b33a87c830dda3793de20c31c8bc38c86df8f7930
EBUILD nltk-3.7.ebuild 1758 BLAKE2B a6186dfa3df9321a7d26951877591a283287a22a1be3e110fc2751223e919695b550aa6b4cbd1ccb7fa9ed9a46a502be31e162dc76aa638fb787053812a3c979 SHA512 57eb93cb2e58d9c1f668e5f4388896d1d966eca983adce95fb3c7ceaab295c49654fe611e3bafb8278ca03270698dbb3863f5933a3174beea3f57b3841257af1
+EBUILD nltk-3.8.1.ebuild 1359 BLAKE2B 92836a33ccf1b0f4363db5f18506f2f09c3ebf2a260ab1948b8a2c16cc44b40d06d753b8bf07457c2d532dc0322c7887723e23844b9aa658d502d6d20bdbedd6 SHA512 f57c5a9bd73b32764fb61e09109aedc438f86846eff62c1b320dfb08b6bc1ca03f634f262bff983507c94daeaea9873df2b792d4bad584f9f6465aa0cc38e228
MISC metadata.xml 445 BLAKE2B 4bfcde721368b9c9354799863a7a78d2c04eb789672f52b5449bda3ef567448fa1b434dda9d150aa0ff360477c576ea2fd0bebce40bf80bb843393e245f85278 SHA512 89bb6d0ca2e268e3540cf36e91b57e834eb31f078a91bb7ed7218a17c1a9b63809ae77916822eabf6a3a86286d00ae4a311b33c52e40d9d2e61b6d242f4cef78
diff --git a/dev-python/nltk/nltk-3.8.1.ebuild b/dev-python/nltk/nltk-3.8.1.ebuild
new file mode 100644
index 0000000..8a88c8b
--- /dev/null
+++ b/dev-python/nltk/nltk-3.8.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite,tk?,xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Natural Language Toolkit"
+HOMEPAGE="https://www.nltk.org/ https://github.com/nltk/nltk/"
+SRC_URI="https://github.com/nltk/nltk/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~ppc64 ~riscv x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="tk"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/joblib[${PYTHON_USEDEP}]
+ dev-python/regex[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/joblib[${PYTHON_USEDEP}]
+ >=dev-python/nltk-data-20211221
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/twython[${PYTHON_USEDEP}]
+ sci-libs/scikit-learn[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ )"
+PDEPEND="dev-python/nltk-data"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ nltk/test/unit/test_downloader.py::test_downloader_using_existing_parent_download_dir
+ nltk/test/unit/test_downloader.py::test_downloader_using_non_existing_parent_download_dir
+)