summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2023-05-21 22:52:47 +0200
committerMarcin Deranek <marcin.deranek@booking.com>2023-05-21 22:59:41 +0200
commit1c34b3d7d8c2f3dd01fb502b0a082d7cc354dcf3 (patch)
tree370e9255fff7801e7c158b29b7381c6713ee4136 /dev-python
parent47c680df36d82604ad0141d938e8f05dc34f1b28 (diff)
downloadportage-1c34b3d7d8c2f3dd01fb502b0a082d7cc354dcf3.tar.gz
portage-1c34b3d7d8c2f3dd01fb502b0a082d7cc354dcf3.tar.bz2
portage-1c34b3d7d8c2f3dd01fb502b0a082d7cc354dcf3.zip
Initial ebuild for dev-python/django-environ
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/django-environ/Manifest3
-rw-r--r--dev-python/django-environ/django-environ-0.10.0.ebuild24
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/django-environ/Manifest b/dev-python/django-environ/Manifest
new file mode 100644
index 0000000..af4710f
--- /dev/null
+++ b/dev-python/django-environ/Manifest
@@ -0,0 +1,3 @@
+DIST django-environ-0.10.0.gh.tar.gz 49508 BLAKE2B 1df34e55fad0072b5be368af880609cb439772ded6446d63e4af03560adc11825e8dda3ac39dddcddf78667a28f0bf26ebc87942c7aaeb5274e56299f240483b SHA512 31296172cb919d2fc295c177618b2af09229943a8683beeeab3da4544bc0aad2eafe64d8ba98c45ede8a0ccd38c63b06425c268c548c47277747b47c21673001
+EBUILD django-environ-0.10.0.ebuild 598 BLAKE2B faa8cad1cc6d7051556554cf30012db4e986b1a44644d6227c500d874052360529f195155f17fce14adfbe4b54bdf4b2bbe254a16a2deba893060db37feb62cb SHA512 427a60cea37f30807c079f4bc613b7a4234b30499f98e8f13223eb0ed3469ff573defae5b6c9c2f60d603a251e7975020148089d1769de5ef5ea441b0299806d
+MISC metadata.xml 463 BLAKE2B b0ed3e5fc9984f2e5dda37723d68e554692406b100c11a996dade95f875c248dd666bf46cc326f6e47612f62c5484549ce3cae277b5fc7fc3cc54bb37c70ffe0 SHA512 460ee8daa813caa312895bfb128b9caea944caef5d4be37e3c818109ff3e83e304b2c6f3f349813bd8701ce3f315188eddebdeaad801ffbcbed1f16bfa55e2ac
diff --git a/dev-python/django-environ/django-environ-0.10.0.ebuild b/dev-python/django-environ/django-environ-0.10.0.ebuild
new file mode 100644
index 0000000..62d29db
--- /dev/null
+++ b/dev-python/django-environ/django-environ-0.10.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="An environment variables to configure Django"
+HOMEPAGE="https://github.com/joke2k/django-environ"
+SRC_URI="https://github.com/joke2k/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/django[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-notfound-page \
+ dev-python/furo