summaryrefslogtreecommitdiff
path: root/dev-python/whitenoise/whitenoise-6.7.0.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@slonko.net>2024-07-13 12:19:49 +0200
committerMarcin Deranek <marcin.deranek@slonko.net>2024-07-13 12:19:59 +0200
commit48cc2dc2f258105e87a0d6bafe6e788ea988e2b6 (patch)
treee5fa8013020a58c777f880fad630b2df009201df /dev-python/whitenoise/whitenoise-6.7.0.ebuild
parent00d5bb45f91e130edfb62ad6df07f1c6ee4710d9 (diff)
downloadportage-48cc2dc2f258105e87a0d6bafe6e788ea988e2b6.tar.gz
portage-48cc2dc2f258105e87a0d6bafe6e788ea988e2b6.tar.bz2
portage-48cc2dc2f258105e87a0d6bafe6e788ea988e2b6.zip
dev-python/whitenoise Version bump
Diffstat (limited to 'dev-python/whitenoise/whitenoise-6.7.0.ebuild')
-rw-r--r--dev-python/whitenoise/whitenoise-6.7.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/whitenoise/whitenoise-6.7.0.ebuild b/dev-python/whitenoise/whitenoise-6.7.0.ebuild
new file mode 100644
index 0000000..6324dd5
--- /dev/null
+++ b/dev-python/whitenoise/whitenoise-6.7.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..12} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Radically simplified static file serving for Python web apps"
+HOMEPAGE="https://github.com/evansd/whitenoise"
+SRC_URI="https://github.com/evansd/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/furo
+
+pkg_postinst() {
+ optfeature "brotli compression" "app-arch/brotli[python]"
+}