summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-hoverxref/sphinx-hoverxref-1.4.0.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@slonko.net>2024-05-31 20:15:54 +0200
committerMarcin Deranek <marcin.deranek@slonko.net>2024-05-31 20:15:54 +0200
commitb713f7ea8c4537ea5c054e7cef63fcbd77eebf10 (patch)
treedf949751f17c0dc3e060b09d12881681b2bb6d3a /dev-python/sphinx-hoverxref/sphinx-hoverxref-1.4.0.ebuild
parent2e1b9c6a10dd2b8270ffc9e55a438c063e519395 (diff)
downloadportage-b713f7ea8c4537ea5c054e7cef63fcbd77eebf10.tar.gz
portage-b713f7ea8c4537ea5c054e7cef63fcbd77eebf10.tar.bz2
portage-b713f7ea8c4537ea5c054e7cef63fcbd77eebf10.zip
dev-python/sphinx-hoverxref Version bump
Diffstat (limited to 'dev-python/sphinx-hoverxref/sphinx-hoverxref-1.4.0.ebuild')
-rw-r--r--dev-python/sphinx-hoverxref/sphinx-hoverxref-1.4.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/sphinx-hoverxref/sphinx-hoverxref-1.4.0.ebuild b/dev-python/sphinx-hoverxref/sphinx-hoverxref-1.4.0.ebuild
new file mode 100644
index 0000000..6eb9abd
--- /dev/null
+++ b/dev-python/sphinx-hoverxref/sphinx-hoverxref-1.4.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension to show tooltips with content embedded when hover a reference"
+HOMEPAGE="
+ https://pypi.org/project/sphinx-hoverxref/
+ https://github.com/readthedocs/sphinx-hoverxref
+"
+SRC_URI="https://github.com/readthedocs/sphinx-hoverxref/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+PROPERTIES="test_network"
+
+RDEPEND="
+ >=dev-python/sphinx-5.0[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-jquery[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/sphinxcontrib-bibtex-2.6.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+#distutils_enable_sphinx docs \
+# dev-python/sphinx-autoapi \
+# dev-python/sphinxcontrib-bibtex \
+# dev-python/sphinx-notfound-page \
+# dev-python/sphinx-prompt \
+# dev-python/sphinx-rtd-theme \
+# dev-python/sphinx-tabs \
+# dev-python/sphinxemoji