summaryrefslogtreecommitdiff
path: root/dev-python/sphinx-click/sphinx-click-6.0.0.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@slonko.net>2024-05-31 20:27:24 +0200
committerMarcin Deranek <marcin.deranek@slonko.net>2024-05-31 20:27:24 +0200
commitcf31c8885be39fadef420683824908b7c5e50370 (patch)
treee555ae83305ab2a83c8b1bafd6e7fe2e92070431 /dev-python/sphinx-click/sphinx-click-6.0.0.ebuild
parentb713f7ea8c4537ea5c054e7cef63fcbd77eebf10 (diff)
downloadportage-cf31c8885be39fadef420683824908b7c5e50370.tar.gz
portage-cf31c8885be39fadef420683824908b7c5e50370.tar.bz2
portage-cf31c8885be39fadef420683824908b7c5e50370.zip
dev-python/sphinx-click Version bump
Diffstat (limited to 'dev-python/sphinx-click/sphinx-click-6.0.0.ebuild')
-rw-r--r--dev-python/sphinx-click/sphinx-click-6.0.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/sphinx-click/sphinx-click-6.0.0.ebuild b/dev-python/sphinx-click/sphinx-click-6.0.0.ebuild
new file mode 100644
index 0000000..f5e1d62
--- /dev/null
+++ b/dev-python/sphinx-click/sphinx-click-6.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx plugin to automatically document click-based applications"
+HOMEPAGE="
+ https://github.com/click-contrib/sphinx-click/
+ https://pypi.org/project/sphinx-click/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/sphinx-4.0[${PYTHON_USEDEP}]
+ >=dev-python/click-8.0[${PYTHON_USEDEP}]
+"
+BDEPEND=">=dev-python/pbr-2.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs --no-autodoc