summaryrefslogtreecommitdiff
path: root/dev-python/shortuuid/shortuuid-1.0.13.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@slonko.net>2024-05-31 20:32:08 +0200
committerMarcin Deranek <marcin.deranek@slonko.net>2024-05-31 20:32:08 +0200
commit80fef02b107c8f194462d328f1175fc130034503 (patch)
tree0676856cf2279f4cf78b3efa921851d239fc3f4d /dev-python/shortuuid/shortuuid-1.0.13.ebuild
parentcf31c8885be39fadef420683824908b7c5e50370 (diff)
downloadportage-80fef02b107c8f194462d328f1175fc130034503.tar.gz
portage-80fef02b107c8f194462d328f1175fc130034503.tar.bz2
portage-80fef02b107c8f194462d328f1175fc130034503.zip
dev-python/shortuuid Version bump
Diffstat (limited to 'dev-python/shortuuid/shortuuid-1.0.13.ebuild')
-rw-r--r--dev-python/shortuuid/shortuuid-1.0.13.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/shortuuid/shortuuid-1.0.13.ebuild b/dev-python/shortuuid/shortuuid-1.0.13.ebuild
new file mode 100644
index 0000000..9440cbd
--- /dev/null
+++ b/dev-python/shortuuid/shortuuid-1.0.13.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A generator library for concise, unambiguous and URL-safe UUIDs."
+HOMEPAGE="https://github.com/skorokithakis/shortuuid"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DOCS=( README.md )
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/COPYING/d' pyproject.toml || die
+ default
+}