summaryrefslogtreecommitdiff
path: root/dev-python/reportlab/files/reportlab-3.6.9-paths.patch
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2023-05-23 06:41:28 +0200
committerMarcin Deranek <marcin.deranek@booking.com>2023-05-23 06:41:28 +0200
commit5d9692d6a67bb2c5a628899b3ed74b0388746908 (patch)
tree6f49e0c017e124bf1d6a2ba86280fc7a480b1b26 /dev-python/reportlab/files/reportlab-3.6.9-paths.patch
parent4ce54254bceda2d01d28295057515f1fe7198a80 (diff)
downloadportage-5d9692d6a67bb2c5a628899b3ed74b0388746908.tar.gz
portage-5d9692d6a67bb2c5a628899b3ed74b0388746908.tar.bz2
portage-5d9692d6a67bb2c5a628899b3ed74b0388746908.zip
Initial ebuild for dev-python/reportlab
Diffstat (limited to 'dev-python/reportlab/files/reportlab-3.6.9-paths.patch')
-rw-r--r--dev-python/reportlab/files/reportlab-3.6.9-paths.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/reportlab/files/reportlab-3.6.9-paths.patch b/dev-python/reportlab/files/reportlab-3.6.9-paths.patch
new file mode 100644
index 0000000..e5ed7c4
--- /dev/null
+++ b/dev-python/reportlab/files/reportlab-3.6.9-paths.patch
@@ -0,0 +1,21 @@
+Disable broken logic for finding freetype2 that hits symlink loops.
+
+diff -dupr reportlab-3.6.9.orig/setup.py reportlab-3.6.9/setup.py
+--- reportlab-3.6.9.orig/setup.py 2022-03-28 10:13:33.892516135 +0200
++++ reportlab-3.6.9/setup.py 2022-03-28 10:49:11.048573739 +0200
+@@ -737,13 +737,10 @@ def main():
+ else:
+ FT_LIB=FT_LIB_DIR=FT_INC_DIR=FT_MACROS=[]
+ else:
+- ftv, I, L = inc_lib_dirs('freetype')
+ FT_LIB=['freetype']
+- FT_LIB_DIR=L
+- FT_INC_DIR=I
++ FT_LIB_DIR=[]
++ FT_INC_DIR=['/usr/include/freetype2']
+ FT_MACROS = [('RENDERPM_FT',None)]
+- infoline('installing with freetype version %s' % ftv)
+- infoline('FT_LIB_DIR=%r FT_INC_DIR=%r' % (FT_LIB_DIR,FT_INC_DIR))
+ if not FT_LIB:
+ infoline('# installing without freetype no ttf, sorry!')
+ infoline('# You need to install a static library version of the freetype2 software')