summaryrefslogtreecommitdiff
path: root/dev-python/python-ipware/python-ipware-3.0.0.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@slonko.net>2024-05-31 20:35:44 +0200
committerMarcin Deranek <marcin.deranek@slonko.net>2024-05-31 20:35:44 +0200
commitb7c29d59d6149fedc919f478caa2a084f4ea88fb (patch)
tree07f25d430c0fecfb84e861f5a3cd128282708ff7 /dev-python/python-ipware/python-ipware-3.0.0.ebuild
parent80fef02b107c8f194462d328f1175fc130034503 (diff)
downloadportage-b7c29d59d6149fedc919f478caa2a084f4ea88fb.tar.gz
portage-b7c29d59d6149fedc919f478caa2a084f4ea88fb.tar.bz2
portage-b7c29d59d6149fedc919f478caa2a084f4ea88fb.zip
dev-python/python-ipware Version bump
Diffstat (limited to 'dev-python/python-ipware/python-ipware-3.0.0.ebuild')
-rw-r--r--dev-python/python-ipware/python-ipware-3.0.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/python-ipware/python-ipware-3.0.0.ebuild b/dev-python/python-ipware/python-ipware-3.0.0.ebuild
new file mode 100644
index 0000000..29c3112
--- /dev/null
+++ b/dev-python/python-ipware/python-ipware-3.0.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="A Python package to retrieve user's IP address"
+HOMEPAGE="
+ https://github.com/un33k/python-ipware
+ https://pypi.org/project/python-ipware/
+"
+SRC_URI="https://github.com/un33k/python-ipware/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests unittest