summaryrefslogtreecommitdiff
path: root/dev-python/langdetect/langdetect-1.0.9.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2023-01-11 09:59:20 +0100
committerMarcin Deranek <marcin.deranek@booking.com>2023-01-11 09:59:20 +0100
commit39fbeae8e681fc40c5fb1e0d7ea40b28be9370ca (patch)
tree066096f0f0ad28b200ba00ac0bbf7db6093f09f9 /dev-python/langdetect/langdetect-1.0.9.ebuild
parentb84e3d882eaca5dc58f02793cc14afe7ad984497 (diff)
downloadportage-39fbeae8e681fc40c5fb1e0d7ea40b28be9370ca.tar.gz
portage-39fbeae8e681fc40c5fb1e0d7ea40b28be9370ca.tar.bz2
portage-39fbeae8e681fc40c5fb1e0d7ea40b28be9370ca.zip
Initial dev-python/langdetect ebuild
Diffstat (limited to 'dev-python/langdetect/langdetect-1.0.9.ebuild')
-rw-r--r--dev-python/langdetect/langdetect-1.0.9.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/langdetect/langdetect-1.0.9.ebuild b/dev-python/langdetect/langdetect-1.0.9.ebuild
new file mode 100644
index 0000000..194327d
--- /dev/null
+++ b/dev-python/langdetect/langdetect-1.0.9.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Port of Google's language-detection library to Python"
+HOMEPAGE="
+ https://pypi.org/project/langdetect/
+ https://github.com/Mimino666/langdetect
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest