summaryrefslogtreecommitdiff
path: root/dev-python/imap-tools/imap-tools-1.6.0.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@slonko.net>2024-05-31 22:22:39 +0200
committerMarcin Deranek <marcin.deranek@slonko.net>2024-05-31 22:22:39 +0200
commitf1558d7cb316e20ab72390024214c5dae1a1fdec (patch)
tree9cb4c2f9703c62e0f66c2bbe17a59720a0c7a87f /dev-python/imap-tools/imap-tools-1.6.0.ebuild
parent0d8506f59d869ffa6266a2f6345c4e8db9926737 (diff)
downloadportage-f1558d7cb316e20ab72390024214c5dae1a1fdec.tar.gz
portage-f1558d7cb316e20ab72390024214c5dae1a1fdec.tar.bz2
portage-f1558d7cb316e20ab72390024214c5dae1a1fdec.zip
dev-python/imap-tools Version bump
Diffstat (limited to 'dev-python/imap-tools/imap-tools-1.6.0.ebuild')
-rw-r--r--dev-python/imap-tools/imap-tools-1.6.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/imap-tools/imap-tools-1.6.0.ebuild b/dev-python/imap-tools/imap-tools-1.6.0.ebuild
new file mode 100644
index 0000000..e8d6803
--- /dev/null
+++ b/dev-python/imap-tools/imap-tools-1.6.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..12} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/_}"
+DESCRIPTION="High level lib for work with email by IMAP"
+HOMEPAGE="https://github.com/ikvk/imap_tools"
+SRC_URI="https://github.com/ikvk/imap_tools/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DOCS=( README.rst )
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ # Remove tests requiring credentials for public IMAP servers
+ rm tests/test_{connection,folders,idle,mailbox,message}.py || die
+
+ distutils-r1_python_prepare_all
+}