summaryrefslogtreecommitdiff
path: root/dev-python/hijridate/hijridate-2.4.1.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@slonko.net>2023-12-09 17:27:58 +0100
committerMarcin Deranek <marcin.deranek@slonko.net>2023-12-09 17:27:58 +0100
commit26db9f1ae19de73e49d004dc6f0a8833b7489000 (patch)
tree99f2fbcd05f6c72681d3a2fe49613e4e9afd0604 /dev-python/hijridate/hijridate-2.4.1.ebuild
parenteef0b8ab8e87ef8a88bfcb1accb3cd6963b803e3 (diff)
downloadportage-26db9f1ae19de73e49d004dc6f0a8833b7489000.tar.gz
portage-26db9f1ae19de73e49d004dc6f0a8833b7489000.tar.bz2
portage-26db9f1ae19de73e49d004dc6f0a8833b7489000.zip
dev-python/hijridate Initial build
Diffstat (limited to 'dev-python/hijridate/hijridate-2.4.1.ebuild')
-rw-r--r--dev-python/hijridate/hijridate-2.4.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/hijridate/hijridate-2.4.1.ebuild b/dev-python/hijridate/hijridate-2.4.1.ebuild
new file mode 100644
index 0000000..87a9378
--- /dev/null
+++ b/dev-python/hijridate/hijridate-2.4.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Hijri-Gregorian date converter"
+HOMEPAGE="https://github.com/dralshehri/hijridate"
+SRC_URI="https://github.com/dralshehri/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+#S="${WORKDIR}/hijridate-${PV}"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/furo \
+ dev-python/myst-parser \
+ dev-python/sphinx-notfound-page