summaryrefslogtreecommitdiff
path: root/dev-python/django-guardian/django-guardian-2.4.0.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2023-05-21 23:08:47 +0200
committerMarcin Deranek <marcin.deranek@booking.com>2023-05-21 23:08:47 +0200
commit4ce54254bceda2d01d28295057515f1fe7198a80 (patch)
tree6e749e8482d611de37d2f478ba0526ea5e995890 /dev-python/django-guardian/django-guardian-2.4.0.ebuild
parent1c34b3d7d8c2f3dd01fb502b0a082d7cc354dcf3 (diff)
downloadportage-4ce54254bceda2d01d28295057515f1fe7198a80.tar.gz
portage-4ce54254bceda2d01d28295057515f1fe7198a80.tar.bz2
portage-4ce54254bceda2d01d28295057515f1fe7198a80.zip
Initial ebuild for dev-python/django-guardian
Diffstat (limited to 'dev-python/django-guardian/django-guardian-2.4.0.ebuild')
-rw-r--r--dev-python/django-guardian/django-guardian-2.4.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/django-guardian/django-guardian-2.4.0.ebuild b/dev-python/django-guardian/django-guardian-2.4.0.ebuild
new file mode 100644
index 0000000..f4945ae
--- /dev/null
+++ b/dev-python/django-guardian/django-guardian-2.4.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Implementation of per object permissions for Django"
+HOMEPAGE="https://github.com/django-guardian/django-guardian"
+SRC_URI="https://github.com/django-guardian/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/django[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ dev-python/django-environ[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme