summaryrefslogtreecommitdiff
path: root/dev-python/django-extensions/django-extensions-3.2.1.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2023-01-04 17:20:48 +0100
committerMarcin Deranek <marcin.deranek@booking.com>2023-01-04 17:20:57 +0100
commit46e9c7e1658a59c3bcf0964508f274746c112c0b (patch)
treea00eb7ae10c8f5136bfb5027b4f337ece0266e75 /dev-python/django-extensions/django-extensions-3.2.1.ebuild
parenteddcfac6b0ca9fc717bc71891e0e84ae46796645 (diff)
downloadportage-46e9c7e1658a59c3bcf0964508f274746c112c0b.tar.gz
portage-46e9c7e1658a59c3bcf0964508f274746c112c0b.tar.bz2
portage-46e9c7e1658a59c3bcf0964508f274746c112c0b.zip
Initial ebuild for dev-python/django-extensions
Diffstat (limited to 'dev-python/django-extensions/django-extensions-3.2.1.ebuild')
-rw-r--r--dev-python/django-extensions/django-extensions-3.2.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/django-extensions/django-extensions-3.2.1.ebuild b/dev-python/django-extensions/django-extensions-3.2.1.ebuild
new file mode 100644
index 0000000..a9753be
--- /dev/null
+++ b/dev-python/django-extensions/django-extensions-3.2.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A collection of custom extensions for the Django Framework"
+HOMEPAGE="https://github.com/django-extensions/django-extensions"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ >=dev-python/django-3.2[${PYTHON_USEDEP}]
+"
+
+DOCS=( README.rst CHANGELOG.md )
+
+# TODO: tests
+#distutils_enable_tests unittest
+#
+#python_test() {
+# "${EPYTHON}" -m django test -v2 --settings=tests.testapp.settings || die "Tests fail with ${EPYTHON}"
+#}