summaryrefslogtreecommitdiff
path: root/dev-python/django-celery-results/django-celery-results-2.5.1.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@slonko.net>2023-07-10 00:03:44 +0200
committerMarcin Deranek <marcin.deranek@slonko.net>2023-07-10 00:03:44 +0200
commitfb77c04d84bc99f835c0a76f9b6ad1370c516b92 (patch)
treef69e669433b15cee0f10d6bcf5156eafd4e2dbc2 /dev-python/django-celery-results/django-celery-results-2.5.1.ebuild
parenteb67afc54c20534a4468192b36ab735fa39c3a75 (diff)
downloadportage-fb77c04d84bc99f835c0a76f9b6ad1370c516b92.tar.gz
portage-fb77c04d84bc99f835c0a76f9b6ad1370c516b92.tar.bz2
portage-fb77c04d84bc99f835c0a76f9b6ad1370c516b92.zip
dev-python/django-celery-results version bump
Diffstat (limited to 'dev-python/django-celery-results/django-celery-results-2.5.1.ebuild')
-rw-r--r--dev-python/django-celery-results/django-celery-results-2.5.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/django-celery-results/django-celery-results-2.5.1.ebuild b/dev-python/django-celery-results/django-celery-results-2.5.1.ebuild
new file mode 100644
index 0000000..759d036
--- /dev/null
+++ b/dev-python/django-celery-results/django-celery-results-2.5.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 pypi
+
+MY_P=${PN//-/_}-${PV}
+DESCRIPTION="Celery Result Backends using the Django ORM/Cache framework."
+HOMEPAGE="https://github.com/celery/django-celery-results"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ >=dev-python/celery-5.2.7[${PYTHON_USEDEP}]
+ <dev-python/celery-6.0[${PYTHON_USEDEP}]
+ >=dev-python/django-3.2.18[${PYTHON_USEDEP}]
+"
+
+DOCS=( README.rst )
+
+#BDEPEND="
+# test? (
+# >=dev-python/pytest-django-4.5.2[${PYTHON_USEDEP}]
+# dev-python/pytz[${PYTHON_USEDEP}]
+# )
+#"
+
+#python_prepare_all() {
+# # Prevent un-needed download during build
+# sed -e "/^ include_intersphinx=/d" \
+# -i docs/conf.py || die
+#
+# distutils-r1_python_prepare_all
+#}
+
+#distutils_enable_tests pytest
+#distutils_enable_sphinx docs \
+# dev-python/sphinx_celery