summaryrefslogtreecommitdiff
path: root/dev-python/dateparser/dateparser-1.1.4.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@slonko.net>2023-07-09 20:43:17 +0200
committerMarcin Deranek <marcin.deranek@slonko.net>2023-07-09 20:44:02 +0200
commit9e69efe984a6a3f7e171d9b5ec7ff8d8ab88a010 (patch)
tree62c73a8feb834670c1acff523fe4eba0982f7c86 /dev-python/dateparser/dateparser-1.1.4.ebuild
parenta7c2870c51b6a78abdb6064713b76d7e506c9b20 (diff)
downloadportage-9e69efe984a6a3f7e171d9b5ec7ff8d8ab88a010.tar.gz
portage-9e69efe984a6a3f7e171d9b5ec7ff8d8ab88a010.tar.bz2
portage-9e69efe984a6a3f7e171d9b5ec7ff8d8ab88a010.zip
dev-python/dateparser version bump
Diffstat (limited to 'dev-python/dateparser/dateparser-1.1.4.ebuild')
-rw-r--r--dev-python/dateparser/dateparser-1.1.4.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/dateparser/dateparser-1.1.4.ebuild b/dev-python/dateparser/dateparser-1.1.4.ebuild
deleted file mode 100644
index cae087e..0000000
--- a/dev-python/dateparser/dateparser-1.1.4.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..11} )
-DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1 optfeature pypi
-
-DESCRIPTION="Date parsing library designed to parse dates from HTML pages"
-HOMEPAGE="https://github.com/scrapinghub/dateparser"
-
-LICENSE="BSD-4"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/regex[${PYTHON_USEDEP}]
- dev-python/tzlocal[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-libs/fastText[python,${PYTHON_USEDEP}]
- dev-python/convertdate[${PYTHON_USEDEP}]
- dev-python/hijri-converter[${PYTHON_USEDEP}]
- dev-python/langdetect[${PYTHON_USEDEP}]
- dev-python/parameterized[${PYTHON_USEDEP}]
- )
-"
-
-EPYTEST_IGNORE=(
- # tests that require network
- tests/test_dateparser_data_integrity.py
-)
-
-EPYTEST_DESELECT=(
- # tests that require network
- tests/test_language_detect.py::CustomLangDetectParserTest::test_custom_language_detect_fast_text_{0,1}
-)
-
-distutils_enable_tests pytest
-
-distutils_enable_sphinx docs \
- dev-python/sphinx-rtd-theme
-
-pkg_postinst() {
- optfeature "calendars support" "dev-python/hijri-converter dev-python/convertdate"
- optfeature "fasttext support" "dev-libs/fastText[python]"
- optfeature "langdetect support" dev-python/langdetect
-}