summaryrefslogtreecommitdiff
path: root/dev-python/daphne/daphne-4.0.0.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@slonko.net>2024-05-31 23:30:53 +0200
committerMarcin Deranek <marcin.deranek@slonko.net>2024-05-31 23:30:53 +0200
commit1f395e53f748479ab4af337a34f30f38ff53df6a (patch)
tree55ac3218857e4bb638c4bd67b175d6c0fb2d3795 /dev-python/daphne/daphne-4.0.0.ebuild
parentc43ed5ea2dfe09f58e9ca4b1a2ce69234d884630 (diff)
downloadportage-1f395e53f748479ab4af337a34f30f38ff53df6a.tar.gz
portage-1f395e53f748479ab4af337a34f30f38ff53df6a.tar.bz2
portage-1f395e53f748479ab4af337a34f30f38ff53df6a.zip
dev-python/daphne Version bump
Diffstat (limited to 'dev-python/daphne/daphne-4.0.0.ebuild')
-rw-r--r--dev-python/daphne/daphne-4.0.0.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/daphne/daphne-4.0.0.ebuild b/dev-python/daphne/daphne-4.0.0.ebuild
deleted file mode 100644
index 38c827f..0000000
--- a/dev-python/daphne/daphne-4.0.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="HTTP, HTTP2 and WebSocket protocol server for ASGI and ASGI-HTTP"
-HOMEPAGE="https://github.com/django/daphne"
-SRC_URI="https://github.com/django/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-
-DEPEND="
- >=dev-python/asgiref-3.5.2[${PYTHON_USEDEP}]
- <dev-python/asgiref-4.0[${PYTHON_USEDEP}]
- >=dev-python/autobahn-22.4.2[${PYTHON_USEDEP}]
- >=dev-python/django-3.2[${PYTHON_USEDEP}]
- >=dev-python/twisted-22.4[ssl,${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- )
-"
-
-DOCS=( README.rst )
-
-distutils_enable_tests pytest
-
-src_test() {
- ASGI_THREADS=4 distutils-r1_src_test
-}