summaryrefslogtreecommitdiff
path: root/dev-python/channels-redis/channels-redis-4.0.0.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2023-05-30 09:37:31 +0200
committerMarcin Deranek <marcin.deranek@booking.com>2023-05-30 09:37:31 +0200
commit09bee9f8fe9823bdc6a3d84f83f6e62235e183bd (patch)
treec429ac0d7ff571a96687b5012812ebb2dd7c6cf1 /dev-python/channels-redis/channels-redis-4.0.0.ebuild
parent218970a47d4415c4999aa7c3f64b95890df432b7 (diff)
downloadportage-09bee9f8fe9823bdc6a3d84f83f6e62235e183bd.tar.gz
portage-09bee9f8fe9823bdc6a3d84f83f6e62235e183bd.tar.bz2
portage-09bee9f8fe9823bdc6a3d84f83f6e62235e183bd.zip
www-apps/paperless-ngx Address msgpack dependency issue
Diffstat (limited to 'dev-python/channels-redis/channels-redis-4.0.0.ebuild')
-rw-r--r--dev-python/channels-redis/channels-redis-4.0.0.ebuild73
1 files changed, 0 insertions, 73 deletions
diff --git a/dev-python/channels-redis/channels-redis-4.0.0.ebuild b/dev-python/channels-redis/channels-redis-4.0.0.ebuild
deleted file mode 100644
index 8b31c7c..0000000
--- a/dev-python/channels-redis/channels-redis-4.0.0.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-MY_P=${P/-/_}
-DESCRIPTION="Provides Django Channels channel layers that use Redis as a backing store."
-HOMEPAGE="https://github.com/django/channels_redis"
-SRC_URI="https://github.com/django/${PN/-/_}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-RDEPEND="
- dev-python/channels[${PYTHON_USEDEP}]
- >=dev-python/django-3.2[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-db/redis
- dev-python/async-timeout[${PYTHON_USEDEP}]
- >=dev-python/cryptography-1.3.0[${PYTHON_USEDEP}]
- dev-python/msgpack[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- >=dev-python/redis-4.2.0[${PYTHON_USEDEP}]
- )
-"
-
-DOCS=( README.rst )
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # Hangs
- tests/test_core.py::test_message_expiry__group_send__one_channel_expires_message
- # Fails with: TypeError: int() argument must be a string, a bytes-like object or a real number, not 'NoneType'
- tests/test_core.py::test_receive_cancel
-)
-
-python_prepare_all() {
- # Remove sentinel tests
- rm tests/test{_pubsub,}_sentinel.py
-
- distutils-r1_python_prepare_all
-}
-
-src_test() {
- local redis_pid="${T}"/redis.pid
- local redis_port=6379
-
- einfo "Spawning Redis"
- einfo "NOTE: Port ${redis_port} must be free"
- "${EPREFIX}"/usr/sbin/redis-server - <<-EOF || die
- daemonize yes
- pidfile ${redis_pid}
- port ${redis_port}
- bind 127.0.0.1
- EOF
-
- # Run the tests
- distutils-r1_src_test
-
- # Clean up afterwards
- kill "$(<"${redis_pid}")" || die
-}