summaryrefslogtreecommitdiff
path: root/dev-python/billiard/billiard-4.1.0.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2023-05-27 23:48:30 +0200
committerMarcin Deranek <marcin.deranek@booking.com>2023-05-27 23:48:30 +0200
commit5cbe2e99ce95b0ced213618c516ef8f299f79907 (patch)
treebedab136d163e58d408a256bb682dff5bdca99b0 /dev-python/billiard/billiard-4.1.0.ebuild
parent707571ef00105371a647c46501341dbeeee52779 (diff)
downloadportage-5cbe2e99ce95b0ced213618c516ef8f299f79907.tar.gz
portage-5cbe2e99ce95b0ced213618c516ef8f299f79907.tar.bz2
portage-5cbe2e99ce95b0ced213618c516ef8f299f79907.zip
dev-python/billiard version bump
Diffstat (limited to 'dev-python/billiard/billiard-4.1.0.ebuild')
-rw-r--r--dev-python/billiard/billiard-4.1.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/billiard/billiard-4.1.0.ebuild b/dev-python/billiard/billiard-4.1.0.ebuild
new file mode 100644
index 0000000..81506c5
--- /dev/null
+++ b/dev-python/billiard/billiard-4.1.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python multiprocessing fork"
+HOMEPAGE="https://github.com/celery/billiard"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+BDEPEND="
+ test? (
+ >=dev-python/psutil-5.9.0[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx Doc