summaryrefslogtreecommitdiff
path: root/dev-lua
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2023-03-13 12:51:33 +0100
committerMarcin Deranek <marcin.deranek@booking.com>2023-03-13 12:51:47 +0100
commit3eb790664f0ffaa6e9f1bcd0ec8d50a42f8733c7 (patch)
tree0eab658e155917e10e9c4ffcc5fa70633298783a /dev-lua
parent09cfa78decc5058e8ffb4db9676a83f1516f972b (diff)
downloadportage-3eb790664f0ffaa6e9f1bcd0ec8d50a42f8733c7.tar.gz
portage-3eb790664f0ffaa6e9f1bcd0ec8d50a42f8733c7.tar.bz2
portage-3eb790664f0ffaa6e9f1bcd0ec8d50a42f8733c7.zip
New ebuild to support lua in nginx-1.23.3
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/resty-core/Manifest2
-rw-r--r--dev-lua/resty-core/metadata.xml12
-rw-r--r--dev-lua/resty-core/resty-core-0.1.23.ebuild54
-rw-r--r--dev-lua/resty-lrucache/Manifest2
-rw-r--r--dev-lua/resty-lrucache/metadata.xml12
-rw-r--r--dev-lua/resty-lrucache/resty-lrucache-0.13.ebuild47
6 files changed, 129 insertions, 0 deletions
diff --git a/dev-lua/resty-core/Manifest b/dev-lua/resty-core/Manifest
new file mode 100644
index 0000000..98da599
--- /dev/null
+++ b/dev-lua/resty-core/Manifest
@@ -0,0 +1,2 @@
+DIST resty-core-0.1.23.tar.gz 169382 BLAKE2B 4a357f3d3f1333e53761cfeabb13b3202baae0d98f89afd5d1f7f7890ddaddc74103e0635a0756d9f8b069a18218ec61ed99d29ef2b323f2dbf27ed21bfb1f9b SHA512 eccae9705217583deca292cd2cb4b7ac03a304926257d1e62a9434c0a08d5fa31546f7d7f196b40c29cad2c560e48daa78d558a11083c9598f7e5242f6099105
+EBUILD resty-core-0.1.23.ebuild 1046 BLAKE2B 596fd061bbba51ca0d0da644aea14cca7096abfdb953fee3eff84d8900a5b60399df3a30ac81fd52204fca4622049ebe32a36e24a602565cedc3326f333034d8 SHA512 7a7922ebaee60f32157546eb9512a1cc9f2b7840666bff56cc0dc63b895afe66e250cb1cee8f18698fd55c4af67cfd038a057a42408f81aa870f140f4d3a95f0
diff --git a/dev-lua/resty-core/metadata.xml b/dev-lua/resty-core/metadata.xml
new file mode 100644
index 0000000..bf06ab6
--- /dev/null
+++ b/dev-lua/resty-core/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marcin.deranek@slonko.net</email>
+ <name>Marcin Deranek</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/openresty/lua-resty-core/issues</bugs-to>
+ <remote-id type="github">openresty/lua-resty-core</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-lua/resty-core/resty-core-0.1.23.ebuild b/dev-lua/resty-core/resty-core-0.1.23.ebuild
new file mode 100644
index 0000000..8423a2c
--- /dev/null
+++ b/dev-lua/resty-core/resty-core-0.1.23.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( luajit )
+
+inherit lua
+
+DESCRIPTION="New LuaJIT FFI based API for lua-nginx-module"
+HOMEPAGE="https://github.com/openresty/lua-resty-core"
+
+if [[ "${PV}" =~ 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/openresty/lua-resty-core"
+else
+ SRC_URI="https://github.com/openresty/lua-resty-core/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/lua-${P}"
+ KEYWORDS="~amd64 ~arm ~x86"
+ # TODO: arm64 and others
+fi
+
+LICENSE="BSD"
+SLOT="0"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+IUSE="+lua_targets_luajit"
+
+RDEPEND="
+ ${LUA_DEPS}
+ www-servers/nginx:*[nginx_modules_http_lua]
+ dev-lua/resty-lrucache[${LUA_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+DOCS+=(docs/.)
+
+src_prepare() {
+ default
+ mkdir -p docs
+ find . -type f -name '*.md' -exec mv -t docs {} ';'
+}
+
+each_lua_install() {
+ insinto "$(lua_get_lmod_dir)"
+ doins -r lib/resty lib/ngx
+}
+
+src_install() {
+ einstalldocs
+ lua_foreach_impl each_lua_install
+}
diff --git a/dev-lua/resty-lrucache/Manifest b/dev-lua/resty-lrucache/Manifest
new file mode 100644
index 0000000..498b479
--- /dev/null
+++ b/dev-lua/resty-lrucache/Manifest
@@ -0,0 +1,2 @@
+DIST resty-lrucache-0.13.tar.gz 17429 BLAKE2B c82bfab854332787cac1ed6d8dc6975d8c1c372119e06361ff792012f7d24970adc189aaf4fccff09fd38240df74d8d981f7475979d769ebac41c63d25639e4e SHA512 d6491acdca5d7b02feef1bf7fafb31798ae3194ad759a9ba87e895ef4e71268a2785291504f73e07e6872bed0d30147ca5e2cd0a0250db11f0a361af43426dfe
+EBUILD resty-lrucache-0.13.ebuild 953 BLAKE2B 328c37a25350e81eb5e090e27b0922c7a714e6282df9c977f6b876e31c961b714bb93909b7c12afbce1e51a3930ebc8d844959cf36efa40323f5b1c354c8db63 SHA512 a66eaa272da9f355fa5a24a1380234f6108320d686b95f2c22286404ac9812bb9476745e3b430e28d8c2f27879d033eca7a5711d3930bd81f89c869771c9f2b5
diff --git a/dev-lua/resty-lrucache/metadata.xml b/dev-lua/resty-lrucache/metadata.xml
new file mode 100644
index 0000000..718dcf0
--- /dev/null
+++ b/dev-lua/resty-lrucache/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marcin.deranek@slonko.net</email>
+ <name>Marcin Deranek</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/openresty/lua-resty-lrucache/issues</bugs-to>
+ <remote-id type="github">openresty/lua-resty-lrucache</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-lua/resty-lrucache/resty-lrucache-0.13.ebuild b/dev-lua/resty-lrucache/resty-lrucache-0.13.ebuild
new file mode 100644
index 0000000..a7059b7
--- /dev/null
+++ b/dev-lua/resty-lrucache/resty-lrucache-0.13.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( luajit )
+
+inherit lua
+
+DESCRIPTION="A simple LRU cache for OpenResty and the ngx_lua module (based on LuaJIT FFI)"
+HOMEPAGE="https://github.com/openresty/lua-resty-lrucache"
+
+if [[ "${PV}" =~ 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/openresty/lua-resty-lrucache"
+else
+ SRC_URI="https://github.com/openresty/lua-resty-lrucache/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/lua-${P}"
+ KEYWORDS="~amd64 ~arm ~x86"
+ # TODO: arm64 and others
+fi
+
+LICENSE="BSD"
+SLOT="0"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+IUSE="+lua_targets_luajit"
+
+RDEPEND="
+ ${LUA_DEPS}
+ www-servers/nginx:*[nginx_modules_http_lua]
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+each_lua_install() {
+ insinto "$(lua_get_lmod_dir)"
+ doins -r lib/resty
+}
+
+src_compile() { :; }
+
+src_install() {
+ lua_foreach_impl each_lua_install
+ einstalldocs
+}