summaryrefslogtreecommitdiff
path: root/dev-libs/stb/stb-20231115.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@slonko.net>2023-12-09 23:04:59 +0100
committerMarcin Deranek <marcin.deranek@slonko.net>2023-12-09 23:04:59 +0100
commitb33c8acd3c045a6a548a6d726b8f69a09e944d34 (patch)
treed7589d88e1e3c3125b514e9315f5f43483983bbc /dev-libs/stb/stb-20231115.ebuild
parent498212cc63f382f49356cb9a4eb11337763913ee (diff)
downloadportage-b33c8acd3c045a6a548a6d726b8f69a09e944d34.tar.gz
portage-b33c8acd3c045a6a548a6d726b8f69a09e944d34.tar.bz2
portage-b33c8acd3c045a6a548a6d726b8f69a09e944d34.zip
dev-libs/stb Initial ebuild
Diffstat (limited to 'dev-libs/stb/stb-20231115.ebuild')
-rw-r--r--dev-libs/stb/stb-20231115.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/stb/stb-20231115.ebuild b/dev-libs/stb/stb-20231115.ebuild
new file mode 100644
index 0000000..d304d1e
--- /dev/null
+++ b/dev-libs/stb/stb-20231115.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# There are no official releases
+CHECKSUM="03f50e343d796e492e6579a11143a085429d7f5d"
+
+DESCRIPTION="single-file public domain (or MIT licensed) libraries for C/C++"
+HOMEPAGE="https://github.com/nothings/stb"
+SRC_URI="https://github.com/nothings/stb/archive/${CHECKSUM}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( MIT Unlicense )"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~x86"
+
+S="${WORKDIR}/${PN}-${CHECKSUM}"
+
+src_prepare() {
+ default
+
+ # Move the header files in a folder so they don't pollute the include dir
+ mkdir stb || die
+ mv *.h stb/ || die
+}
+
+src_install() {
+ doheader -r stb
+}