summaryrefslogtreecommitdiff
path: root/dev-lang
diff options
context:
space:
mode:
authorMarcin Deranek <gringo@slonko.net>2019-01-12 22:56:59 +0100
committerMarcin Deranek <gringo@slonko.net>2019-01-12 22:56:59 +0100
commit5f9ab942ba225f0b6f86840b1f48f40b05edb35b (patch)
treeb800831e571490a06dc9d76d69ec8dca628ea0df /dev-lang
parent5c9722d4f665c8d881d89a8a5a398ff821a638ab (diff)
downloadportage-5f9ab942ba225f0b6f86840b1f48f40b05edb35b.tar.gz
portage-5f9ab942ba225f0b6f86840b1f48f40b05edb35b.tar.bz2
portage-5f9ab942ba225f0b6f86840b1f48f40b05edb35b.zip
Add Scratch
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/squeakvm/Manifest2
-rw-r--r--dev-lang/squeakvm/squeakvm-4.10.2.2614.ebuild173
2 files changed, 175 insertions, 0 deletions
diff --git a/dev-lang/squeakvm/Manifest b/dev-lang/squeakvm/Manifest
new file mode 100644
index 0000000..c08456e
--- /dev/null
+++ b/dev-lang/squeakvm/Manifest
@@ -0,0 +1,2 @@
+DIST Squeak-4.10.2.2614-src.tar.gz 3297314 BLAKE2B 03c89ea96ed005f1d7a25e6b1016f39bec2dbd7e2282a12c1b02ab57859477d87e3098426c55411fc06e250207830b7e50a23e6330ca64fd967613f2af86e180 SHA512 b823fb97f7826dbbae5feeb15ffc3ab7e11cf27c5a3cc3f2cf2f8c39b56af5f9d0078d020a4b8f72b997198d296be6d85ec10e0bca10d5214bf586e1e0587f07
+EBUILD squeakvm-4.10.2.2614.ebuild 3934 BLAKE2B 165a8ba90f496611f3c0e26dfcddf4d4b165540bbca94aa8179f0bbe51b149632fc6ee7c9fe8bf13e1590685eea2d99413674602629fa75007cbc781c5b39bcb SHA512 5f1ff4415a35dfef84c5d680884ab7d142c27b7c7f0dca5a3c40079ec7371e3fcb00b33b4b6510ca039e8e942ed6ff1e9f41fb8925cebf753d34a2a368711bc0
diff --git a/dev-lang/squeakvm/squeakvm-4.10.2.2614.ebuild b/dev-lang/squeakvm/squeakvm-4.10.2.2614.ebuild
new file mode 100644
index 0000000..571ee79
--- /dev/null
+++ b/dev-lang/squeakvm/squeakvm-4.10.2.2614.ebuild
@@ -0,0 +1,173 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+EAPI=6
+inherit versionator fixheadtails
+DESCRIPTION="Highly-portable Smalltalk-80 implementation"
+HOMEPAGE="http://www.squeak.org/"
+SRC_URI="http://squeakvm.org/unix/release/Squeak-${PV}-src.tar.gz"
+LICENSE="Apple"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="+X +mmx +threads +iconv +opengl image64 alsa oss pulseaudio nas +v4l fbcon dbus +scratch examples"
+
+
+DEPEND="X? ( x11-libs/libX11 x11-libs/libXext x11-libs/libXt )
+ dev-util/cmake
+ media-libs/freetype
+ >=x11-libs/cairo-1.8.6
+ >=x11-libs/pango-1.20.5
+ >=dev-libs/glib-2.20.1:2
+ virtual/libffi
+ sys-apps/util-linux
+ iconv? ( virtual/libiconv )
+ opengl? ( virtual/opengl )
+ v4l? ( >=media-libs/libv4l-0.5.8 )
+ alsa? ( media-libs/alsa-lib )
+ oss? ( || ( media-libs/alsa-oss media-sound/oss ) )
+ pulseaudio? ( media-sound/pulseaudio )
+ nas? ( media-libs/nas )
+ dbus? ( sys-apps/dbus )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/Squeak-${PV}-src"
+
+src_prepare() {
+ ht_fix_all
+ eapply_user
+ if ! use examples; then
+ rm -rf unix/vm-display-custom
+ rm -rf unix/vm-sound-custom
+ fi
+}
+
+src_configure() {
+ local myconf=""
+ if use X; then
+ myconf="${myconf} --with-x"
+ else
+ myconf="${myconf} --without-x"
+ fi
+ if use threads; then
+ myconf="${myconf} --enable-mpg-pthread"
+ else
+ myconf="${myconf} --disable-mpg-pthread"
+ fi
+ if use iconv; then
+ myconf="${myconf} --enable-iconv"
+ else
+ myconf="${myconf} --disable-iconv"
+ fi
+
+ if use opengl; then
+ myconf="${myconf} --with-gl"
+ else
+ myconf="${myconf} --without-gl"
+ fi
+
+ if use alsa; then
+ myconf="${myconf} --with-alsa"
+ else
+ myconf="${myconf} --without-alsa"
+ fi
+
+ if use oss; then
+ myconf="${myconf} --with-oss"
+ else
+ myconf="${myconf} --without-oss"
+ fi
+
+ if use pulseaudio; then
+ myconf="${myconf} --with-pulse"
+ else
+ myconf="${myconf} --without-pulse"
+ fi
+
+ if use nas; then
+ myconf="${myconf} --with-NAS"
+ else
+ myconf="${myconf} --without-NAS"
+ fi
+
+ if use v4l; then
+ myconf="${myconf} --with-CameraPlugin"
+ else
+ myconf="${myconf} --without-CameraPlugin"
+ fi
+
+ if use fbcon; then
+ myconf="${myconf} --with-fbdev"
+ else
+ myconf="${myconf} --without-fbdev"
+ fi
+
+ if use dbus; then
+ myconf="${myconf} --with-DBusPlugin"
+ else
+ myconf="${myconf} --without-DBusPlugin"
+ fi
+
+ if use scratch; then
+ myconf="${myconf} --with-ScratchPlugin"
+ else
+ myconf="${myconf} --without-ScratchPlugin"
+ fi
+
+
+ if use X; then
+ myconf="${myconf} --with-x"
+ else
+ myconf="${myconf} --without-x"
+ fi
+
+
+ if use X; then
+ myconf="${myconf} --with-x"
+ else
+ myconf="${myconf} --without-x"
+ fi
+
+
+
+
+ #use mmx && myconf="${myconf} --enable-mpg-mmx"
+ #use threads && myconf="${myconf} --enable-mpg-pthread"
+ #use iconv || myconf="${myconf} --disable-iconv"
+ #use opengl || myconf="${myconf} --without-gl"
+ use image64 && myconf="${myconf} --image64"
+ #use alsa || myconf="${myconf} --without-alsa"
+ #use oss || myconf="${myconf} --without-OSS"
+ #use pulseaudio || myconf="${myconf} --without-pulse"
+ #use nas || myconf="${myconf} --without-NAS"
+ #use v4l || myconf="${myconf} --without-CameraPlugin"
+ #use fbcon || myconf="${myconf} --without-fbdev"
+ #use dbus || myconf="${myconf} --without-DBusPlugin"
+ #use scratch || myconf="${myconf} --without-ScratchPlugin"
+
+
+
+ cd ${S}
+ touch unix/npsqueak/CMakeLists.txt
+ mkdir build
+ cd build
+ ../unix/cmake/configure \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --with-ffi=x86-sysv \
+ --without-npsqueak \
+ --without-quartz \
+ --without-Sun \
+ --without-MaxOSX \
+ --without-WeDoPlugin \
+ --with-FT2Plugin \
+ --with-SqueakFFIPrims \
+ ${myconf} || die "configure failed"
+}
+
+src_install() {
+ dodoc README unix/ChangeLog
+ cd ${S}/build
+ emake DESTDIR=${D} ROOT=${D} docdir=/usr/share/doc/${PF} install || die
+ exeinto /usr/lib/squeak
+ exeinto /usr/lib/ckformat
+}