summaryrefslogtreecommitdiff
path: root/dev-lang
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@slonko.net>2020-03-09 13:34:12 +0100
committerMarcin Deranek <marcin.deranek@slonko.net>2020-03-09 13:34:12 +0100
commit1c42b2c617f2b2932b2a12e3f49cdf0d929f6aea (patch)
tree0ac0f4c3beba7f129be210eaee68b173dba14b30 /dev-lang
parentfb66cc7d1c59596a9cc1a5d3b952e475d48f9a6b (diff)
downloadportage-1c42b2c617f2b2932b2a12e3f49cdf0d929f6aea.tar.gz
portage-1c42b2c617f2b2932b2a12e3f49cdf0d929f6aea.tar.bz2
portage-1c42b2c617f2b2932b2a12e3f49cdf0d929f6aea.zip
Repo fixes and cleanups
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/squeakvm/Manifest2
-rw-r--r--dev-lang/squeakvm/squeakvm-4.10.2.2614.ebuild16
2 files changed, 8 insertions, 10 deletions
diff --git a/dev-lang/squeakvm/Manifest b/dev-lang/squeakvm/Manifest
index c08456e..0478227 100644
--- a/dev-lang/squeakvm/Manifest
+++ b/dev-lang/squeakvm/Manifest
@@ -1,2 +1,2 @@
DIST Squeak-4.10.2.2614-src.tar.gz 3297314 BLAKE2B 03c89ea96ed005f1d7a25e6b1016f39bec2dbd7e2282a12c1b02ab57859477d87e3098426c55411fc06e250207830b7e50a23e6330ca64fd967613f2af86e180 SHA512 b823fb97f7826dbbae5feeb15ffc3ab7e11cf27c5a3cc3f2cf2f8c39b56af5f9d0078d020a4b8f72b997198d296be6d85ec10e0bca10d5214bf586e1e0587f07
-EBUILD squeakvm-4.10.2.2614.ebuild 3934 BLAKE2B 165a8ba90f496611f3c0e26dfcddf4d4b165540bbca94aa8179f0bbe51b149632fc6ee7c9fe8bf13e1590685eea2d99413674602629fa75007cbc781c5b39bcb SHA512 5f1ff4415a35dfef84c5d680884ab7d142c27b7c7f0dca5a3c40079ec7371e3fcb00b33b4b6510ca039e8e942ed6ff1e9f41fb8925cebf753d34a2a368711bc0
+EBUILD squeakvm-4.10.2.2614.ebuild 3921 BLAKE2B dc33239856722575aa2d2ec0d60f9a0b5f0b95ff125bc8d2826785fe3e9aca299325f81919a4f97b8fb3358adfb50fa440692091d7593560c2d5895846e29ae9 SHA512 c63d2f2880fde6fc3f76a3e11b4fcaf03c36aba8ad048d786271911268409047f514f2333a327ecb6b26ca3022b57bd62e8f296b6f0d3e3efa32bfa89461e4c1
diff --git a/dev-lang/squeakvm/squeakvm-4.10.2.2614.ebuild b/dev-lang/squeakvm/squeakvm-4.10.2.2614.ebuild
index 571ee79..8071784 100644
--- a/dev-lang/squeakvm/squeakvm-4.10.2.2614.ebuild
+++ b/dev-lang/squeakvm/squeakvm-4.10.2.2614.ebuild
@@ -1,20 +1,20 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit versionator fixheadtails
+inherit versionator fixheadtails
DESCRIPTION="Highly-portable Smalltalk-80 implementation"
HOMEPAGE="http://www.squeak.org/"
SRC_URI="http://squeakvm.org/unix/release/Squeak-${PV}-src.tar.gz"
LICENSE="Apple"
SLOT="0"
-KEYWORDS="~x86 ~amd64"
+KEYWORDS="~amd64 ~x86"
IUSE="+X +mmx +threads +iconv +opengl image64 alsa oss pulseaudio nas +v4l fbcon dbus +scratch examples"
-DEPEND="X? ( x11-libs/libX11 x11-libs/libXext x11-libs/libXt )
+DEPEND="X? ( x11-libs/libX11 x11-libs/libXext x11-libs/libXt )
dev-util/cmake
media-libs/freetype
- >=x11-libs/cairo-1.8.6
+ >=x11-libs/cairo-1.8.6
>=x11-libs/pango-1.20.5
>=dev-libs/glib-2.20.1:2
virtual/libffi
@@ -133,7 +133,7 @@ src_configure() {
#use threads && myconf="${myconf} --enable-mpg-pthread"
#use iconv || myconf="${myconf} --disable-iconv"
#use opengl || myconf="${myconf} --without-gl"
- use image64 && myconf="${myconf} --image64"
+ use image64 && myconf="${myconf} --image64"
#use alsa || myconf="${myconf} --without-alsa"
#use oss || myconf="${myconf} --without-OSS"
#use pulseaudio || myconf="${myconf} --without-pulse"
@@ -143,12 +143,10 @@ src_configure() {
#use dbus || myconf="${myconf} --without-DBusPlugin"
#use scratch || myconf="${myconf} --without-ScratchPlugin"
-
-
cd ${S}
- touch unix/npsqueak/CMakeLists.txt
+ touch unix/npsqueak/CMakeLists.txt
mkdir build
- cd build
+ cd build
../unix/cmake/configure \
--prefix=/usr \
--infodir=/usr/share/info \