summaryrefslogtreecommitdiff
path: root/app-text/OCRmyPDF/OCRmyPDF-14.0.1.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2023-01-08 16:05:49 +0100
committerMarcin Deranek <marcin.deranek@booking.com>2023-01-08 16:05:49 +0100
commit63083430bc6f4fc47fd241febb566b0121bbf422 (patch)
treec777bc1a5db045ef56dde18049ec511ab880f203 /app-text/OCRmyPDF/OCRmyPDF-14.0.1.ebuild
parent323aedb1e05714f2bf53f208ba82099a448c0202 (diff)
downloadportage-63083430bc6f4fc47fd241febb566b0121bbf422.tar.gz
portage-63083430bc6f4fc47fd241febb566b0121bbf422.tar.bz2
portage-63083430bc6f4fc47fd241febb566b0121bbf422.zip
app-text/OCRmyPDF version bump
Diffstat (limited to 'app-text/OCRmyPDF/OCRmyPDF-14.0.1.ebuild')
-rw-r--r--app-text/OCRmyPDF/OCRmyPDF-14.0.1.ebuild67
1 files changed, 0 insertions, 67 deletions
diff --git a/app-text/OCRmyPDF/OCRmyPDF-14.0.1.ebuild b/app-text/OCRmyPDF/OCRmyPDF-14.0.1.ebuild
deleted file mode 100644
index 3664bec..0000000
--- a/app-text/OCRmyPDF/OCRmyPDF-14.0.1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 2020-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit bash-completion-r1 distutils-r1 optfeature
-
-DESCRIPTION="OCRmyPDF adds an OCR text layer to scanned PDF files"
-HOMEPAGE="https://github.com/ocrmypdf/OCRmyPDF"
-SRC_URI="https://github.com/ocrmypdf/OCRmyPDF/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- >=app-text/ghostscript-gpl-9.50
- >=app-text/pdfminer-20201018[${PYTHON_USEDEP}]
- >=app-text/tesseract-4.1.1[jpeg,tiff,png,webp]
- >=dev-python/coloredlogs-14.0[${PYTHON_USEDEP}]
- >=dev-python/deprecation-2.1.0[${PYTHON_USEDEP}]
- >=dev-python/packaging-20[${PYTHON_USEDEP}]
- >=dev-python/pikepdf-5.0.1[${PYTHON_USEDEP}]
- >=dev-python/pillow-8.2.0[lcms,${PYTHON_USEDEP}]
- >=dev-python/pluggy-0.13.0[${PYTHON_USEDEP}]
- >=dev-python/reportlab-3.5.66[${PYTHON_USEDEP}]
- >=dev-python/tqdm-4[${PYTHON_USEDEP}]
- >=media-gfx/img2pdf-0.3.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/setuptools_scm-7.0.5[${PYTHON_USEDEP}]
- test? (
- >=app-text/unpaper-6.1
- dev-python/pytest-helpers-namespace[${PYTHON_USEDEP}]
- ~dev-python/python-xmp-toolkit-2.0.1[${PYTHON_USEDEP}]
- >=media-libs/jbig2enc-0.29
- >=media-gfx/pngquant-2.5
- )
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs \
- dev-python/sphinx-issues \
- dev-python/sphinx_rtd_theme
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-src_prepare() {
- distutils-r1_src_prepare
- sed -e "/-n auto/d" -i pyproject.toml || die
-}
-
-src_install() {
- distutils-r1_src_install
- newbashcomp misc/completion/ocrmypdf.bash "${PN,,}"
- insinto /usr/share/fish/vendor_completions.d
- doins misc/completion/ocrmypdf.fish
-}
-
-pkg_postinst() {
- optfeature "JBIG2 optimization support" media-libs/jbig2enc
- optfeature "image cleaning support" app-text/unpaper
- optfeature "PNG optimization support" media-gfx/pngquant
-}