summaryrefslogtreecommitdiff
path: root/app-misc/open-plc-utils/open-plc-utils-9999.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <gringo@slonko.net>2015-09-20 10:52:09 +0200
committerMarcin Deranek <gringo@slonko.net>2015-09-20 10:52:09 +0200
commit64477fb2cc405b1c99aa4aa1da216f740ef13bac (patch)
tree0f58af0faa9f840f46e8c26323bc2c01a64c34d5 /app-misc/open-plc-utils/open-plc-utils-9999.ebuild
parent5504e79caecd068e3c6c9c4c3a62a9d960bbea6a (diff)
downloadportage-64477fb2cc405b1c99aa4aa1da216f740ef13bac.tar.gz
portage-64477fb2cc405b1c99aa4aa1da216f740ef13bac.tar.bz2
portage-64477fb2cc405b1c99aa4aa1da216f740ef13bac.zip
Added open-plc-utils
Diffstat (limited to 'app-misc/open-plc-utils/open-plc-utils-9999.ebuild')
-rw-r--r--app-misc/open-plc-utils/open-plc-utils-9999.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-misc/open-plc-utils/open-plc-utils-9999.ebuild b/app-misc/open-plc-utils/open-plc-utils-9999.ebuild
new file mode 100644
index 0000000..58a83a7
--- /dev/null
+++ b/app-misc/open-plc-utils/open-plc-utils-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} = 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/qca/open-plc-utils.git"
+ S=${WORKDIR}/open-plc-utils-${PV}
+else
+ SRC_URI="https://github.com/qca/open-plc-utils/archive/v${PV}.tar.gz -> python-diamond-${PV}.tar.gz"
+ S=${WORKDIR}/open-plc-utils-${PV}
+fi
+
+DESCRIPTION="Qualcomm Atheros Open Powerline Toolkit. "
+HOMEPAGE="https://github.com/qca/open-plc-utils"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+src_install() {
+ emake ROOTFS="${D}" install || die "emake install failed"
+ emake ROOTFS="${D}" manuals || die "emake manuals failed"
+ use doc && dohtml -r docbook
+}