summaryrefslogtreecommitdiff
path: root/app-arch
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2023-04-23 19:51:37 +0200
committerMarcin Deranek <marcin.deranek@booking.com>2023-04-23 19:51:37 +0200
commitaafb5698393bc1d5301d8cd0f4c04bc33f572ba8 (patch)
treeda0c4e263271157ee1158f34e43ff1cfe5fe6aa1 /app-arch
parent4e6fdec9f62693ec38ef5ff91d59c81fec4e87f5 (diff)
downloadportage-aafb5698393bc1d5301d8cd0f4c04bc33f572ba8.tar.gz
portage-aafb5698393bc1d5301d8cd0f4c04bc33f572ba8.tar.bz2
portage-aafb5698393bc1d5301d8cd0f4c04bc33f572ba8.zip
Add missing ebuild files
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/gztool/gztool-1.6.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-arch/gztool/gztool-1.6.0.ebuild b/app-arch/gztool/gztool-1.6.0.ebuild
new file mode 100644
index 0000000..102c63e
--- /dev/null
+++ b/app-arch/gztool/gztool-1.6.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="GZIP files indexer, compressor and data retriever."
+HOMEPAGE="https://github.com/circulosmeos/gztool"
+SRC_URI="https://github.com/circulosmeos/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+DEPEND="sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}