summaryrefslogtreecommitdiff
path: root/app-arch/gztool/gztool-1.1.1.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@slonko.net>2021-06-19 15:00:21 +0200
committerMarcin Deranek <marcin.deranek@slonko.net>2021-06-19 15:00:21 +0200
commitbc175d8a4d2d12fb1f53d51ab6a07dad6dd64754 (patch)
tree978ec4bb45ed16c5ac6570a79f9baf92333bead7 /app-arch/gztool/gztool-1.1.1.ebuild
parentc5a2aece1a46ff4e57886ab5b5351995cf493e6c (diff)
downloadportage-bc175d8a4d2d12fb1f53d51ab6a07dad6dd64754.tar.gz
portage-bc175d8a4d2d12fb1f53d51ab6a07dad6dd64754.tar.bz2
portage-bc175d8a4d2d12fb1f53d51ab6a07dad6dd64754.zip
Add initial build for gztool
Diffstat (limited to 'app-arch/gztool/gztool-1.1.1.ebuild')
-rw-r--r--app-arch/gztool/gztool-1.1.1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/app-arch/gztool/gztool-1.1.1.ebuild b/app-arch/gztool/gztool-1.1.1.ebuild
new file mode 100644
index 0000000..5cd4579
--- /dev/null
+++ b/app-arch/gztool/gztool-1.1.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="GZIP files indexer, compressor and data retriever."
+HOMEPAGE="https://github.com/circulosmeos/gztool"
+SRC_URI="https://github.com/circulosmeos/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+src_prepare() {
+ default
+ eautoreconf
+}