summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@slonko.net>2021-03-17 09:47:52 +0100
committerMarcin Deranek <marcin.deranek@slonko.net>2021-03-17 09:47:52 +0100
commitded6ccb127c476e65db434ab994eb9fb27c08621 (patch)
tree1d1253a38475b1992407378a2db130e5a8052381
parent57b590586bd6b95066a366f6f0c9c454ebec3682 (diff)
downloadportage-ded6ccb127c476e65db434ab994eb9fb27c08621.tar.gz
portage-ded6ccb127c476e65db434ab994eb9fb27c08621.tar.bz2
portage-ded6ccb127c476e65db434ab994eb9fb27c08621.zip
hardened-sources version bump
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-5.11.6.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-kernel/hardened-sources/hardened-sources-5.11.6.ebuild b/sys-kernel/hardened-sources/hardened-sources-5.11.6.ebuild
new file mode 100644
index 0000000..e28a9e4
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-5.11.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="7"
+K_NODRYRUN="1"
+
+inherit kernel-2
+detect_version
+detect_arch
+SUBREL="hardened1"
+HARDENED_URI="https://github.com/anthraxx/linux-hardened/releases/download/${PV}-${SUBREL}/linux-hardened-${PV}-${SUBREL}.patch"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+HOMEPAGE="https://github.com/anthraxx/linux-hardened https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+UNIPATCH_LIST="${DISTDIR}/linux-hardened-${PV}-${SUBREL}.patch"
+UNIPATCH_EXCLUDE="1510_fs-enable-link-security-restrictions-by-default.patch"
+
+DESCRIPTION="Minimal supplement to upstream Kernel Self Protection Project"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${HARDENED_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}