summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@slonko.net>2024-06-19 22:36:35 +0200
committerMarcin Deranek <marcin.deranek@slonko.net>2024-06-19 22:36:47 +0200
commitbd9f16568209dcd5a09cd96d85e5cab8e934e27f (patch)
treeadc094c564fc0c188163d29c56db0088eb389e08
parenta044c473bb0ff9e18ee41fb907b46c9126efc131 (diff)
downloadportage-bd9f16568209dcd5a09cd96d85e5cab8e934e27f.tar.gz
portage-bd9f16568209dcd5a09cd96d85e5cab8e934e27f.tar.bz2
portage-bd9f16568209dcd5a09cd96d85e5cab8e934e27f.zip
dev-python/djangorestframework Version bump
-rw-r--r--dev-python/djangorestframework/Manifest2
-rw-r--r--dev-python/djangorestframework/djangorestframework-3.15.2.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/djangorestframework/Manifest b/dev-python/djangorestframework/Manifest
index 4cc2bde..c17dd7f 100644
--- a/dev-python/djangorestframework/Manifest
+++ b/dev-python/djangorestframework/Manifest
@@ -1,3 +1,5 @@
DIST django-rest-framework-3.14.0.gh.tar.gz 9056443 BLAKE2B 217be67f42207d72d862011a72aecef3e111c1e1dd4b4e090cae6b22dee3fb32e060f7877c498084cf1221eb960b4ca895ef55721f7cabaafe3e36ee152e17a8 SHA512 c1012c656b427e0318b2056e2f984ddc75a5b4e85f375c76fba165ad06e285848eee1bc6dc76c097daec57d780efb2551110199d62ce636a03951aec13ab4013
+DIST django-rest-framework-3.15.2.gh.tar.gz 9290406 BLAKE2B 588aebbdd89f749bacd4244707f6b4b0e2a6aef0759973e5451ebcc4acb4d2e1c2d9773ab576e33442f5123ce860cae087622a26d1d208edc70df04057c4d401 SHA512 a24322fb09398ee1608900ae623d8ba44c3cb066fc7921e38f847a93513d3ca549d933da6cfc045a556edfe50dae3431b6782d0241a9f53ac3dbc0caf48fa520
EBUILD djangorestframework-3.14.0.ebuild 1307 BLAKE2B 41b40dd945007763cb9c35451b78a2b5eda5263b4cd1a0c95102cc7da2bcca09474f6ebabceb1847f79573936313865c2123b2797cf25a6062b7f48fe75d0e3f SHA512 5ac1a0b7dd41f3cc52d3ad2d356469fecd5f55053930d7ce5df9fb694a3744a14f39404fa36c2bc421bab3498fc01557e9e2d3bf783e54593fd4e1afdf830f14
+EBUILD djangorestframework-3.15.2.ebuild 1580 BLAKE2B 4104bb883508a9b46397d8af23e2ae0c570d0123eed908d34b4841d9c2d57dd39a52a239c37d9b730f64f5fa5d5e6019d96e3c2a8534a1a83eb44fc5b7fe4d92 SHA512 4c236c411ac7bc1c8ffa17528a55111878da8b52822dbebca6bfcbc27285d5dd6d0b84dd05bf85efc05f3b46927b0d98c64e3c25daa846daa6e1c5d07bd70011
MISC metadata.xml 430 BLAKE2B daa4a7fa4c2085627f8a903457f3ebbbbebccba7cf54124bbd0c60b2a05f9bb05a6b303ea6b4b517c406fbfd759803ab3fb95ce45c7c85afa905aadbcb63c905 SHA512 6f15c657338d3cf689da4178b7288d8763fa00b2cc48a5e97e1a669fdcff309ab4ed742183369395ff8292c6627011365b3dcbd44eb77503a98ea47452652fa3
diff --git a/dev-python/djangorestframework/djangorestframework-3.15.2.ebuild b/dev-python/djangorestframework/djangorestframework-3.15.2.ebuild
new file mode 100644
index 0000000..4bcf2d5
--- /dev/null
+++ b/dev-python/djangorestframework/djangorestframework-3.15.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=django-rest-framework-${PV}
+DESCRIPTION="Web APIs with django made easy"
+HOMEPAGE="
+ https://www.django-rest-framework.org/
+ https://github.com/encode/django-rest-framework/
+ https://pypi.org/project/djangorestframework/
+"
+SRC_URI="
+ https://github.com/encode/django-rest-framework/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/django-3.0[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/inflection[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ tests/test_description.py::TestViewNamesAndDescriptions::test_markdown
+
+ # require coreapi (but not skipped properly)
+ tests/schemas/test_managementcommand.py::GenerateSchemaTests::test_coreapi_renders_default_schema_with_custom_title_url_and_desc
+ tests/schemas/test_managementcommand.py::GenerateSchemaTests::test_coreapi_renders_openapi_json_schema
+ tests/schemas/test_managementcommand.py::GenerateSchemaTests::test_renders_corejson_schema
+
+ # upstream is removing pytz, apparently it's not tested anymore
+ # https://github.com/encode/django-rest-framework/discussions/9342
+ tests/test_fields.py::TestPytzNaiveDayLightSavingTimeTimeZoneDateTimeField::test_invalid_inputs
+)