summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@slonko.net>2024-02-28 23:41:41 +0100
committerMarcin Deranek <marcin.deranek@slonko.net>2024-02-28 23:41:41 +0100
commitbb0b4f82156b05d3b003e4100dde9bd25c6db419 (patch)
tree2bca7d991be5b3ac382fcf14659e1bdec7257f61
parent0cb086ce5d15c269a12de4a7f20a22c244c5d6ca (diff)
downloadportage-bb0b4f82156b05d3b003e4100dde9bd25c6db419.tar.gz
portage-bb0b4f82156b05d3b003e4100dde9bd25c6db419.tar.bz2
portage-bb0b4f82156b05d3b003e4100dde9bd25c6db419.zip
dev-python/python3-openid new ebuild
-rw-r--r--dev-python/python3-openid/Manifest3
-rw-r--r--dev-python/python3-openid/metadata.xml13
-rw-r--r--dev-python/python3-openid/python3-openid-3.2.0.ebuild33
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/python3-openid/Manifest b/dev-python/python3-openid/Manifest
new file mode 100644
index 0000000..04b41fe
--- /dev/null
+++ b/dev-python/python3-openid/Manifest
@@ -0,0 +1,3 @@
+DIST python3-openid-3.2.0.tar.gz 305600 BLAKE2B d793eb61335d7240d5c25324b8377d19781df15012c8da6d5d0d7445c8a7fcb31711156b48d32efae8b6de27509e8f9112535ece7820779ca9b7f2e7be04fb0f SHA512 54412820fef21928e1bf30d16c9bc73d454e9ff41df028a12047c08abdb4c2c9e1d9053daebab8b0327cb0fe0f67e364c2506a47509fef6db5bff42f8399b799
+EBUILD python3-openid-3.2.0.ebuild 679 BLAKE2B 805b4b45756dd30106b964502022b7e4efc53f80ed7730a8b96b1a843a22d330b257fc3c023979f47f857c7ffc67b792de0a36d097683b7ef4507dbea1fbf54f SHA512 0b6a07d5e6ae7b5062a275ef1d6de9ac1063504633d2270a2ab47cd5f2c6c9032db298d5f5f2b1e604845cff6aad773e51120262e6e889982f4507d5e0075daa
+MISC metadata.xml 465 BLAKE2B 13d59e0e7c411bebdf18756721d500782b64ab134a8d824d0affc897079e8dcabdbfd49f3c6a437124b6cc0a8a61dc4f80696979e17c404942d66b841b61e850 SHA512 9df2e6d83ce3d3b8b3d9e752d2d9b3b80330cfc40a91dfd894d7ddba982af4433b68abfd402d64d7a2459624bcc02df1f29356e96d363a3f4b7a3abc0b4f123e
diff --git a/dev-python/python3-openid/metadata.xml b/dev-python/python3-openid/metadata.xml
new file mode 100644
index 0000000..ae8bd4e
--- /dev/null
+++ b/dev-python/python3-openid/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marcin.deranek@slonko.net</email>
+ <name>Marcin Deranek</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/necaris/python3-openid/issues</bugs-to>
+ <remote-id type="github">necaris/python3-openid</remote-id>
+ <remote-id type="pypi">python3-openid</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python3-openid/python3-openid-3.2.0.ebuild b/dev-python/python3-openid/python3-openid-3.2.0.ebuild
new file mode 100644
index 0000000..a23c1f7
--- /dev/null
+++ b/dev-python/python3-openid/python3-openid-3.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
+PYPI_NO_NORMALIZE=1
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="OpenID support for modern servers and consumers"
+HOMEPAGE="https://github.com/necaris/python3-openid"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/psycopg:2[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( NEWS.md README.md )
+
+distutils_enable_tests unittest
+python_test() {
+ "${EPYTHON}" -m unittest -v openid.test.test_suite || die "Tests failed with ${EPYTHON}"
+}