summaryrefslogtreecommitdiff
path: root/lxde-base/lxdm/lxdm-0.5.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'lxde-base/lxdm/lxdm-0.5.3.ebuild')
-rw-r--r--lxde-base/lxdm/lxdm-0.5.3.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/lxde-base/lxdm/lxdm-0.5.3.ebuild b/lxde-base/lxdm/lxdm-0.5.3.ebuild
new file mode 100644
index 0000000..87433cd
--- /dev/null
+++ b/lxde-base/lxdm/lxdm-0.5.3.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxdm/lxdm-0.4.1-r8.ebuild,v 1.2 2013/12/22 12:46:59 pacho Exp $
+
+EAPI="5"
+
+WANT_AUTOMAKE="1.12" #493996
+inherit eutils autotools systemd
+
+DESCRIPTION="LXDE Display Manager"
+HOMEPAGE="http://lxde.org"
+SRC_URI="mirror://sourceforge/lxdm/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+
+IUSE="consolekit debug gnome-keyring gtk3 nls pam selinux"
+
+RDEPEND="consolekit? ( sys-auth/consolekit )
+ x11-libs/libxcb
+ gtk3? ( x11-libs/gtk+:3 )
+ !gtk3? ( x11-libs/gtk+:2 )
+ nls? ( sys-devel/gettext )
+ pam? ( virtual/pam )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig"
+
+src_prepare() {
+ cd "${S}"
+ # Upstream bug, tarball contains pre-made lxdm.conf
+ rm data/lxdm.conf || die
+
+ sed -i -e '/pam_console.so/d' pam/lxdm
+
+ if ! use selinux; then
+ sed -i -e '/pam_selinux.so/d' pam/lxdm
+ fi
+ if ! use gnome-keyring; then
+ sed -i -e '/pam_gnome_keyring.so/d' pam/lxdm
+ fi
+ # Allow user to apply any additional patches without modifing ebuild
+ epatch_user
+
+ # this replaces the bootstrap/autogen script in most packages
+ eautoreconf
+
+ # process LINGUAS
+ if use nls; then
+ einfo "Running intltoolize ..."
+ intltoolize --force --copy --automake || die
+ strip-linguas -i "${S}/po" || die
+ fi
+}
+src_configure() {
+ econf --enable-password \
+ --with-x \
+ --with-xconn=xcb \
+ $(use_enable consolekit) \
+ $(use_enable gtk3) \
+ $(use_enable nls) \
+ $(use_enable debug) \
+ $(use_with pam)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS COPYING INSTALL README TODO || die
+}
+
+pkg_postinst() {
+ echo
+ elog "Take into consideration that LXDM is in the early stages of development!"
+ echo
+}