summaryrefslogtreecommitdiff
path: root/games-board/polyglot/polyglot-1.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-board/polyglot/polyglot-1.4.ebuild')
-rw-r--r--games-board/polyglot/polyglot-1.4.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/games-board/polyglot/polyglot-1.4.ebuild b/games-board/polyglot/polyglot-1.4.ebuild
deleted file mode 100644
index d83d1f5..0000000
--- a/games-board/polyglot/polyglot-1.4.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=5
-
-inherit games
-
-MY_P="${PN}_${PV/./}"
-
-DESCRIPTION="UCI adapter to connect a UCI chess engine to an xboard interface"
-HOMEPAGE="http://wbec-ridderkerk.nl/html/details1/PolyGlot.html"
-SRC_URI="http://wbec-ridderkerk.nl/html/downloada/fruit/${MY_P}.zip"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="examples"
-
-DEPEND="app-arch/unzip"
-RDEPEND=""
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Respect {CXX,LD}FLAGS, don't strip
- sed -i \
- -e "s:\(CXX\|LD\)FLAGS \+=:\1FLAGS +=:" \
- -e "/LDFLAGS.*-s/d" \
- src/Makefile || die "sed in Makefile failed"
-}
-
-src_compile() {
- cd src
- emake || die "emake failed"
-}
-
-src_install() {
- dogamesbin src/${PN} || die "dobin failed"
- dodoc readme.txt || die "dodoc failed"
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r "${WORKDIR}"/example/* || die "doins failed"
- fi
-}