summaryrefslogtreecommitdiff
path: root/x11-drivers
diff options
context:
space:
mode:
authorMarcin Deranek <gringo@slonko.net>2016-01-30 08:00:45 +0100
committerMarcin Deranek <gringo@slonko.net>2016-01-30 08:00:45 +0100
commit37197a883b98f2cfb860d1b27fb82280e6c4ebb9 (patch)
tree473e170f8e066d09343f1f1268b9555188ef67a5 /x11-drivers
parent663311d74374f1e0456c1246c5fbca8211cd0aac (diff)
downloadportage-37197a883b98f2cfb860d1b27fb82280e6c4ebb9.tar.gz
portage-37197a883b98f2cfb860d1b27fb82280e6c4ebb9.tar.bz2
portage-37197a883b98f2cfb860d1b27fb82280e6c4ebb9.zip
Add xf86-video-ati from git
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-ati/Manifest1
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-9999.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-ati/Manifest b/x11-drivers/xf86-video-ati/Manifest
new file mode 100644
index 0000000..e249365
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/Manifest
@@ -0,0 +1 @@
+EBUILD xf86-video-ati-9999.ebuild 1019 SHA256 9f826fef78b83b493ddb6ed6ad612c9e5073da18c75be24f574aec8878d73cc3 SHA512 1849f05edb8d7d1e5cf1dadece42d8ff841111ccf633efdbb7c9ef9c5e633ed42ea85be84063b625ebdfbbc7dd50d46fbea143a076ca3650cde264d594c26eb1 WHIRLPOOL 3824efbddeb9804225ba249a31e69534c2e03dbc144715051ea55adef8b129d70f429eb1df22d3829f95adb9ab7cd7b99d7a7b0929eb8f3e58ff5a4affa88bb3
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-9999.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-9999.ebuild
new file mode 100644
index 0000000..5f0939b
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+XORG_DRI=always
+inherit linux-info xorg-2
+
+DESCRIPTION="ATI video driver"
+HOMEPAGE="http://www.x.org/wiki/ati/"
+
+if [[ $PV == 9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+fi
+
+IUSE="+glamor udev"
+
+RDEPEND=">=x11-libs/libdrm-2.4.58[video_cards_radeon]
+ >=x11-libs/libpciaccess-0.8.0
+ glamor? ( x11-base/xorg-server[glamor] )
+ udev? ( virtual/udev )"
+DEPEND="${RDEPEND}
+ x11-proto/fontsproto
+ x11-proto/randrproto
+ x11-proto/renderproto
+ x11-proto/videoproto
+ x11-proto/xextproto
+ x11-proto/xf86driproto
+ x11-proto/xproto"
+
+pkg_pretend() {
+ if use kernel_linux ; then
+ if kernel_is -ge 3 9; then
+ CONFIG_CHECK="~!DRM_RADEON_UMS ~!FB_RADEON"
+ else
+ CONFIG_CHECK="~DRM_RADEON_KMS ~!FB_RADEON"
+ fi
+ fi
+ check_extra_config
+}
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable glamor)
+ $(use_enable udev)
+ )
+ xorg-2_src_configure
+}