summaryrefslogtreecommitdiff
path: root/lxde-base
diff options
context:
space:
mode:
authorMarcin Deranek <gringo@slonko.net>2014-11-08 13:54:25 +0100
committerMarcin Deranek <gringo@slonko.net>2014-11-08 13:54:25 +0100
commit939ade5c62d221d48e5e84f3437ee02c77970019 (patch)
treec50dacf8ed063d2bf71b6f5dd5e05dedfa30d9bf /lxde-base
parent61bcb625c5b7c0c35eff633a206185bb84af4a62 (diff)
downloadportage-939ade5c62d221d48e5e84f3437ee02c77970019.tar.gz
portage-939ade5c62d221d48e5e84f3437ee02c77970019.tar.bz2
portage-939ade5c62d221d48e5e84f3437ee02c77970019.zip
New release of lxdm
Diffstat (limited to 'lxde-base')
-rw-r--r--lxde-base/lxdm/Manifest2
-rw-r--r--lxde-base/lxdm/lxdm-0.5.0.ebuild70
2 files changed, 72 insertions, 0 deletions
diff --git a/lxde-base/lxdm/Manifest b/lxde-base/lxdm/Manifest
new file mode 100644
index 0000000..5eac72b
--- /dev/null
+++ b/lxde-base/lxdm/Manifest
@@ -0,0 +1,2 @@
+DIST lxdm-0.5.0.tar.xz 236972 SHA256 6e876fe8cc52341f3f55c54517da1c6dcf794aa11caffbf5a929ded442a949d4 SHA512 b25fe570699a94a41f294f20375adebdb5ac0f8f3911c45d2ecafa1c103b7b91353660d7b2ffd01468c5dc156f449a42dd391e795603999ebba6b8b41071d17f WHIRLPOOL 6b58502186ed9e16e712de4ce5a6658c132da5d508354f0be355d86271a2c190a24d83531ac3a5ea06c5725ceadf675162847b6549ddebb8b1fb00ab1a53b86d
+EBUILD lxdm-0.5.0.ebuild 1620 SHA256 9a3aa0e54c043161f7ed76fec8b0ac29e9c4be7ff720da28a06def36f2cc9060 SHA512 cc3d7ca11018e22d6bfc609041606f9620ad84f46e5e3ccd348990927104b778c5446f28fd0a55de90f4871d6f285fe923ca809be0c89a283768b2ac587da59e WHIRLPOOL 17fc6f5c1218c6ace6032981e3cb010dfcded862d9a5483c99209dedec7d427d4c450bf072f411fc4d002ca057b42eb5f34841889ab860316dd847e03baafd1f
diff --git a/lxde-base/lxdm/lxdm-0.5.0.ebuild b/lxde-base/lxdm/lxdm-0.5.0.ebuild
new file mode 100644
index 0000000..deac830
--- /dev/null
+++ b/lxde-base/lxdm/lxdm-0.5.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxdm/lxdm-0.4.1-r8.ebuild,v 1.2 2013/12/22 12:46:59 pacho Exp $
+
+EAPI="5"
+
+WANT_AUTOMAKE="1.12" #493996
+inherit eutils autotools systemd
+
+DESCRIPTION="LXDE Display Manager"
+HOMEPAGE="http://lxde.org"
+SRC_URI="mirror://sourceforge/lxdm/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+
+IUSE="consolekit debug gtk3 nls pam"
+
+RDEPEND="consolekit? ( sys-auth/consolekit )
+ x11-libs/libxcb
+ gtk3? ( x11-libs/gtk+:3 )
+ !gtk3? ( x11-libs/gtk+:2 )
+ nls? ( sys-devel/gettext )
+ pam? ( virtual/pam )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig"
+
+src_prepare() {
+ cd "${S}"
+ # Upstream bug, tarball contains pre-made lxdm.conf
+ rm data/lxdm.conf || die
+
+ sed -i -e '/pam_console.so/d' pam/lxdm
+
+ # Allow user to apply any additional patches without modifing ebuild
+ epatch_user
+
+ # this replaces the bootstrap/autogen script in most packages
+ eautoreconf
+
+ # process LINGUAS
+ if use nls; then
+ einfo "Running intltoolize ..."
+ intltoolize --force --copy --automake || die
+ strip-linguas -i "${S}/po" || die
+ fi
+}
+src_configure() {
+ econf --enable-password \
+ --with-x \
+ --with-xconn=xcb \
+ $(use_enable consolekit) \
+ $(use_enable gtk3) \
+ $(use_enable nls) \
+ $(use_enable debug) \
+ $(use_with pam)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS COPYING INSTALL README TODO || die
+}
+
+pkg_postinst() {
+ echo
+ elog "Take into consideration that LXDM is in the early stages of development!"
+ echo
+}