summaryrefslogtreecommitdiff
path: root/games-board
diff options
context:
space:
mode:
authorMarcin Deranek <gringo@slonko.net>2014-10-20 19:29:23 +0200
committerMarcin Deranek <gringo@slonko.net>2014-10-20 19:29:23 +0200
commit8cda91f592eae07fe971e01df866f23d217ad198 (patch)
treed28fdcf2b40054287aed267568581e6486c972cf /games-board
parente7900f5e6e44bc6a2cf6c4f25fa27f739d24c9d3 (diff)
downloadportage-8cda91f592eae07fe971e01df866f23d217ad198.tar.gz
portage-8cda91f592eae07fe971e01df866f23d217ad198.tar.bz2
portage-8cda91f592eae07fe971e01df866f23d217ad198.zip
Added stockfish chess engine
Diffstat (limited to 'games-board')
-rw-r--r--games-board/polyglot/Manifest2
-rw-r--r--games-board/polyglot/polyglot-1.4.ebuild47
-rw-r--r--games-board/stockfish/Manifest2
-rw-r--r--games-board/stockfish/stockfish-5.ebuild65
4 files changed, 116 insertions, 0 deletions
diff --git a/games-board/polyglot/Manifest b/games-board/polyglot/Manifest
new file mode 100644
index 0000000..f9bc28b
--- /dev/null
+++ b/games-board/polyglot/Manifest
@@ -0,0 +1,2 @@
+DIST polyglot_14.zip 229546 SHA256 850af826217023c74e00a3e4333d3693c086ca25e7f34e5cebaebd5597d6697a SHA512 0f7f010d33dd1daf2fd1280b14e50d3204354aefd68939d2d614e93f1f96ab7347032ba3188057041f1aceaafbf47e999c6dd5fe441ae6a913dacb2614f2b6f0 WHIRLPOOL 2f7ba228fd0a05bdeb07d38ac63c8e9fd57a19578431e48bad55d0c5d7cf2f2884a21284cdf1631a011a085d53e2be5fdce7caf4445c736b1e43b198b6b09559
+EBUILD polyglot-1.4.ebuild 981 SHA256 a917c6f82cf518f6082789e791f7cf7ecd82418779434f37e6cf400b792baf8c SHA512 427444f11af94233715792977c38bea919a5d061a1e51db0dd33687d60e6ba9185df5899665cf0b39deda14534a29cec24fca4038a83bf7c65a0c3388ef0775f WHIRLPOOL 40ab1e903db814b571e9d04476df42d39464f787d80b484136362dfba1b7505f098d7434f18251a95fac698f3c1a7cc04efdf2487a3e52cba1d58409fa390711
diff --git a/games-board/polyglot/polyglot-1.4.ebuild b/games-board/polyglot/polyglot-1.4.ebuild
new file mode 100644
index 0000000..d796e70
--- /dev/null
+++ b/games-board/polyglot/polyglot-1.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit games
+
+MY_P="${PN}_${PV/./}"
+
+DESCRIPTION="UCI adapter to connect a UCI chess engine to an xboard interface"
+HOMEPAGE="http://wbec-ridderkerk.nl/html/details1/PolyGlot.html"
+SRC_URI="http://wbec-ridderkerk.nl/html/downloada/fruit/${MY_P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Respect {CXX,LD}FLAGS, don't strip
+ sed -i \
+ -e "s:\(CXX\|LD\)FLAGS \+=:\1FLAGS +=:" \
+ -e "/LDFLAGS.*-s/d" \
+ src/Makefile || die "sed in Makefile failed"
+}
+
+src_compile() {
+ cd src
+ emake || die "emake failed"
+}
+
+src_install() {
+ dogamesbin src/${PN} || die "dobin failed"
+ dodoc readme.txt || die "dodoc failed"
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r "${WORKDIR}"/example/* || die "doins failed"
+ fi
+}
diff --git a/games-board/stockfish/Manifest b/games-board/stockfish/Manifest
new file mode 100644
index 0000000..ca7bf32
--- /dev/null
+++ b/games-board/stockfish/Manifest
@@ -0,0 +1,2 @@
+DIST stockfish-5-linux.zip 594229 SHA256 2af16941e6227dd5232fa257bad6fd99180d31631fc0e26ba5cba3c74f0bab42 SHA512 142e5b179612404417ee686e1971ae4d49c31a4db646a0190016984defd306899af909867891d505919c89322554addba9f14d4c5077490d926054862221d15e WHIRLPOOL 271de9fcb41dc3fd25c92cd1a5380fbb37d3a446c1f2115111285401bee352e6951506abecbc8021756f045bdc05c52d0d27fdf1a8ff9d3b48a34566248efcc0
+EBUILD stockfish-5.ebuild 1465 SHA256 de2fbc8e9d98684815310a1a1b10a76cbc44ee275920bdc9fe68a6c4e5bb41fd SHA512 3260d290a5f937d591172fed0b1acede7d9c9a680bf40a43db1008365bac29844ee7e6f66bf07b260e6066f48c32fa61169fbc7db6b843820a101fa02f725b06 WHIRLPOOL f6b1684393da1a40deb1516c6065c07c7a2038de1d92e369b783c1afb425beeae5341aedc7d1c8ac56edeb08c9bc24ee0a547a6ecbbb401ef6aaf3ea3a2f982b
diff --git a/games-board/stockfish/stockfish-5.ebuild b/games-board/stockfish/stockfish-5.ebuild
new file mode 100644
index 0000000..95dd07b
--- /dev/null
+++ b/games-board/stockfish/stockfish-5.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+inherit games toolchain-funcs
+
+DESCRIPTION="UCI chess engine http://www.stockfishchess.com/"
+HOMEPAGE="http://www.stockfishchess.com/"
+SRC_URI="http://stockfish.s3.amazonaws.com/stockfish-${PV}-linux.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug optimization"
+
+case $(tc-arch) in
+ "x86" ) IUSE+=" sse" ;;
+ "amd64" ) IUSE+=" popcnt" ;;
+esac
+
+DEPEND="optimization? ( sys-devel/gcc[lto] )"
+
+S="${WORKDIR}/${PN}-${PV}-linux/src"
+
+pkg_setup() {
+ games_pkg_setup
+}
+
+src_compile() {
+ local makeopts="ARCH="
+
+ case $(tc-arch) in
+ "x86" )
+ makeopts+="x86-32"
+ ! use sse && makeopts+="-old"
+ ;;
+ "amd64" )
+ makeopts+="x86-64"
+ use popcnt && makeopts+="-modern"
+ ;;
+ esac
+
+ use debug && makeopts+=" debug=yes"
+ ! use optimization && makeopts+=" optimize=no"
+
+ emake build ${makeopts} || die "emake failed"
+}
+
+src_install() {
+ dogamesbin stockfish || die "dogamesbin failed"
+ dodoc ../Copying.txt ../Readme.md || die "dodoc failed"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog
+ elog "Note: The opening book hasn't been installed. If you want it, just"
+ elog " download it from ${HOMEPAGE}."
+ elog " In most cases you take now your xboard compatible application,"
+ elog " (xboard, eboard, knights) and just play chess against computer"
+ elog " opponent. Have fun."
+ elog
+}