summaryrefslogtreecommitdiff
path: root/dev-python/python3-openid/python3-openid-3.2.0.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@slonko.net>2024-02-28 23:41:41 +0100
committerMarcin Deranek <marcin.deranek@slonko.net>2024-02-28 23:41:41 +0100
commitbb0b4f82156b05d3b003e4100dde9bd25c6db419 (patch)
tree2bca7d991be5b3ac382fcf14659e1bdec7257f61 /dev-python/python3-openid/python3-openid-3.2.0.ebuild
parent0cb086ce5d15c269a12de4a7f20a22c244c5d6ca (diff)
downloadportage-bb0b4f82156b05d3b003e4100dde9bd25c6db419.tar.gz
portage-bb0b4f82156b05d3b003e4100dde9bd25c6db419.tar.bz2
portage-bb0b4f82156b05d3b003e4100dde9bd25c6db419.zip
dev-python/python3-openid new ebuild
Diffstat (limited to 'dev-python/python3-openid/python3-openid-3.2.0.ebuild')
-rw-r--r--dev-python/python3-openid/python3-openid-3.2.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/python3-openid/python3-openid-3.2.0.ebuild b/dev-python/python3-openid/python3-openid-3.2.0.ebuild
new file mode 100644
index 0000000..a23c1f7
--- /dev/null
+++ b/dev-python/python3-openid/python3-openid-3.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
+PYPI_NO_NORMALIZE=1
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="OpenID support for modern servers and consumers"
+HOMEPAGE="https://github.com/necaris/python3-openid"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/psycopg:2[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( NEWS.md README.md )
+
+distutils_enable_tests unittest
+python_test() {
+ "${EPYTHON}" -m unittest -v openid.test.test_suite || die "Tests failed with ${EPYTHON}"
+}