summaryrefslogtreecommitdiff
path: root/dev-python/djangorestframework/djangorestframework-3.14.0.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@slonko.net>2024-04-06 21:56:48 +0200
committerMarcin Deranek <marcin.deranek@slonko.net>2024-04-06 21:56:48 +0200
commit8ec16a0512bc753ea4e8bb0c1a16980799d8643d (patch)
tree889adc438cbf3516089bbf8895781b89fe5d55bf /dev-python/djangorestframework/djangorestframework-3.14.0.ebuild
parentda983e9777452a1dcc94114cd44c0a7573242872 (diff)
downloadportage-8ec16a0512bc753ea4e8bb0c1a16980799d8643d.tar.gz
portage-8ec16a0512bc753ea4e8bb0c1a16980799d8643d.tar.bz2
portage-8ec16a0512bc753ea4e8bb0c1a16980799d8643d.zip
www-apps/paperless-ngx version bump
Diffstat (limited to 'dev-python/djangorestframework/djangorestframework-3.14.0.ebuild')
-rw-r--r--dev-python/djangorestframework/djangorestframework-3.14.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/djangorestframework/djangorestframework-3.14.0.ebuild b/dev-python/djangorestframework/djangorestframework-3.14.0.ebuild
new file mode 100644
index 0000000..9cd99ed
--- /dev/null
+++ b/dev-python/djangorestframework/djangorestframework-3.14.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=django-rest-framework-${PV}
+DESCRIPTION="Web APIs with django made easy"
+HOMEPAGE="
+ https://www.django-rest-framework.org/
+ https://github.com/encode/django-rest-framework/
+ https://pypi.org/project/djangorestframework/
+"
+SRC_URI="
+ https://github.com/encode/django-rest-framework/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/django-3.0[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ tests/test_description.py::TestViewNamesAndDescriptions::test_markdown
+
+ # require coreapi (but not skipped properly)
+ tests/schemas/test_managementcommand.py::GenerateSchemaTests::test_coreapi_renders_default_schema_with_custom_title_url_and_desc
+ tests/schemas/test_managementcommand.py::GenerateSchemaTests::test_coreapi_renders_openapi_json_schema
+ tests/schemas/test_managementcommand.py::GenerateSchemaTests::test_renders_corejson_schema
+)