summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorMarcin Deranek <gringo@slonko.net>2019-01-12 22:55:02 +0100
committerMarcin Deranek <gringo@slonko.net>2019-01-12 22:55:02 +0100
commit9e22ecbfdcf8a80d428a11e5dc180f7326f51eec (patch)
tree39465da4904c9f79f9603b53f35f1e3ba8f6f3ab /x11-wm
parent8af5ebb621c7e4a99a7cd6d41ef8f0d93fb5e287 (diff)
downloadportage-9e22ecbfdcf8a80d428a11e5dc180f7326f51eec.tar.gz
portage-9e22ecbfdcf8a80d428a11e5dc180f7326f51eec.tar.bz2
portage-9e22ecbfdcf8a80d428a11e5dc180f7326f51eec.zip
Updated to build
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/compiz/Manifest4
-rw-r--r--x11-wm/compiz/compiz-0.9.13.9999.ebuild176
2 files changed, 91 insertions, 89 deletions
diff --git a/x11-wm/compiz/Manifest b/x11-wm/compiz/Manifest
index 41401c1..fc67d88 100644
--- a/x11-wm/compiz/Manifest
+++ b/x11-wm/compiz/Manifest
@@ -1,2 +1,2 @@
-AUX access_violation.patch 1456 SHA256 efcfe62878821c78eee374508762f4cb769ee7f19235c8d6deb7a81b031690b8 SHA512 04af43f754aca8490e8462562311372e12306bb89aa3c9ed4ac466c65827f17a9f379c1250ad0881c0b3db18a068fd458a7275c8184851d72519a71f1e4fc3f1 WHIRLPOOL 43c5e35f202fc1e5a44168cea3b25ee92d5dbce1bfd62a06e188f534b81eb8b41b5fa050dbf8f82d0336fea05be9c5ea7afecb30af613f3a889b31836adcd5e5
-EBUILD compiz-0.9.13.9999.ebuild 3826 SHA256 f89f004edf18b3f3019a69fd22365d5ab8c3d4c02d212dde2011986a61e41c87 SHA512 0d891dae80304bbd66e155f513517d6969b1bfefa2efab09156032432de77264d4dfcd65861b4671ffc7a05ea4835f7338590c85be7be21369046c8d642db606 WHIRLPOOL 83836e3848e0cbee83fccebeec55099375308e2d6e7dc7d782c1db22d31a0245f2553ea50f5fe935d42dd4c2a0048a28e2585eac2dc76a7d6c4187d96aeabceb
+AUX access_violation.patch 1456 BLAKE2B 4f41e05f549cec2cc4fe234f9c6a97d49a2dfc8c3b0536d2245253afaba96520f083694dffd2c9d58c71f3040ff967c82923c216fad25775287b6c1c5018e1d0 SHA512 04af43f754aca8490e8462562311372e12306bb89aa3c9ed4ac466c65827f17a9f379c1250ad0881c0b3db18a068fd458a7275c8184851d72519a71f1e4fc3f1
+EBUILD compiz-0.9.13.9999.ebuild 3611 BLAKE2B c815399e13331fd85454f14cea076751e4309862e5adc571a753681ec7dd9cae1ab685a47632c647bfa82726afd730a8ea34f15240eba92f4946dd43751ceb6b SHA512 cb168c754c2678ec1e6fd067113f62201577b32fe133d6e797508383fb215be26b9187374e4ea3072c505854898d22e66831747e867f54eba81726f3e306ab9a
diff --git a/x11-wm/compiz/compiz-0.9.13.9999.ebuild b/x11-wm/compiz/compiz-0.9.13.9999.ebuild
index 7a53478..68a9345 100644
--- a/x11-wm/compiz/compiz-0.9.13.9999.ebuild
+++ b/x11-wm/compiz/compiz-0.9.13.9999.ebuild
@@ -1,7 +1,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
inherit cmake-utils eutils gnome2-utils python-single-r1 toolchain-funcs versionator
@@ -36,68 +36,69 @@ COMMONDEPEND="
!x11-apps/ccsm
!dev-python/compizconfig-python
!x11-apps/fusion-icon
- dev-libs/boost
- dev-libs/glib:2
- dev-cpp/glibmm
- dev-libs/libxml2
- dev-libs/libxslt
- dev-python/pyrex
- dev-libs/protobuf
- media-libs/libpng
- x11-base/xorg-server
- x11-libs/libX11
- x11-libs/libXcomposite
- x11-libs/libXdamage
- x11-libs/libXext
- x11-libs/libXrandr
- x11-libs/libXrender
- x11-libs/libXinerama
- x11-libs/libICE
- x11-libs/libSM
- x11-libs/startup-notification
- virtual/opengl
- virtual/glu
- cairo? ( x11-libs/cairo[X] )
- fuse? ( sys-fs/fuse )
- gtk? (
- x11-libs/gtk+:3
- x11-libs/libwnck:3
- x11-libs/pango
- gnome? (
- gnome-base/gnome-desktop
- gnome-base/gconf
- x11-wm/metacity
- )
- )
- kde? ( kde-base/kwin:4 )
- svg? (
- gnome-base/librsvg:2
- x11-libs/cairo
- )
- dbus? ( sys-apps/dbus )"
+ dev-libs/boost
+ dev-libs/glib:2
+ dev-cpp/glibmm
+ dev-libs/libxml2
+ dev-libs/libxslt
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/pyrex
+ dev-libs/protobuf
+ media-libs/libpng
+ x11-base/xorg-server
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXinerama
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/startup-notification
+ virtual/opengl
+ virtual/glu
+ cairo? ( x11-libs/cairo[X] )
+ fuse? ( sys-fs/fuse )
+ gtk? (
+ x11-libs/gtk+:3
+ x11-libs/libwnck:3
+ x11-libs/pango
+ gnome? (
+ gnome-base/gnome-desktop
+ gnome-base/gconf
+ x11-wm/metacity
+ )
+ )
+ kde? ( kde-base/kwin:4 )
+ svg? (
+ gnome-base/librsvg:2
+ x11-libs/cairo
+ )
+ dbus? ( sys-apps/dbus )"
DEPEND="${COMMONDEPEND}
- app-admin/chrpath
- virtual/pkgconfig
- x11-proto/damageproto
- x11-proto/xineramaproto
- test? (
- dev-cpp/gtest
- dev-cpp/gmock
- )"
+ app-admin/chrpath
+ virtual/pkgconfig
+ x11-proto/damageproto
+ x11-proto/xineramaproto
+ test? (
+ dev-cpp/gtest
+ dev-cpp/gmock
+ )"
RDEPEND="${COMMONDEPEND}
- dev-python/pygtk
- x11-apps/mesa-progs
- x11-apps/xvinfo
- x11-themes/hicolor-icon-theme"
+ dev-python/pygtk
+ x11-apps/mesa-progs
+ x11-apps/xvinfo
+ x11-themes/hicolor-icon-theme"
pkg_pretend() {
- if [[ ${MERGE_TYPE} != binary ]]; then
- [[ $(gcc-major-version) -lt 4 ]] || \
- ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 6 ]] ) \
- && die "Sorry, but gcc 4.6 or higher is required."
- fi
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ [[ $(gcc-major-version) -lt 4 ]] || \
+ ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 6 ]] ) \
+ && die "Sorry, but gcc 4.6 or higher is required."
+ fi
}
src_unpack() {
@@ -109,51 +110,52 @@ src_unpack() {
}
src_prepare() {
+ sed -i -e 's/CYTHON_BIN cython3/CYTHON_BIN cython/' compizconfig/compizconfig-python/CMakeLists.txt
epatch "${FILESDIR}"/access_violation.patch
eapply_user
}
pkg_setup() {
- python-single-r1_pkg_setup
+ python-single-r1_pkg_setup
}
src_configure() {
- use debug && CMAKE_BUILD_TYPE=Debug
- local mycmakeargs=(
- "-DUSE_GLES=$(usex gles)"
- "-DUSE_GNOME=$(usex gnome)"
- "-DUSE_METACITY=$(usex gnome)"
- "-DUSE_GTK=$(usex gtk)"
- "-DUSE_KDE4=$(usex kde)"
- "-DCOMPIZ_BUILD_TESTING=$(usex test)"
- "-DCMAKE_BUILD_TYPE=Release"
- "-DCMAKE_INSTALL_PREFIX=/usr"
- "-DCOMPIZ_DEFAULT_PLUGINS=composite,opengl,decor,resize,place,move,ccp"
- "-DCOMPIZ_DISABLE_SCHEMAS_INSTALL=On"
- "-DCOMPIZ_PACKAGING_ENABLED=On"
- "-DCOMPIZ_BUILD_WITH_RPATH=Off"
- "-DCOMPIZ_BUILD_TESTING=Off"
- "-DCOMPIZ_WERROR=Off"
- "-Wno-dev"
- )
- cmake-utils_src_configure
+ use debug && CMAKE_BUILD_TYPE=Debug
+ local mycmakeargs=(
+ "-DUSE_GLES=$(usex gles)"
+ "-DUSE_GNOME=$(usex gnome)"
+ "-DUSE_METACITY=$(usex gnome)"
+ "-DUSE_GTK=$(usex gtk)"
+ "-DUSE_KDE4=$(usex kde)"
+ "-DCOMPIZ_BUILD_TESTING=$(usex test)"
+ "-DCMAKE_BUILD_TYPE=Release"
+ "-DCMAKE_INSTALL_PREFIX=/usr"
+ "-DCOMPIZ_DEFAULT_PLUGINS=composite,opengl,decor,resize,place,move,ccp"
+ "-DCOMPIZ_DISABLE_SCHEMAS_INSTALL=On"
+ "-DCOMPIZ_PACKAGING_ENABLED=On"
+ "-DCOMPIZ_BUILD_WITH_RPATH=Off"
+ "-DCOMPIZ_BUILD_TESTING=Off"
+ "-DCOMPIZ_WERROR=Off"
+ "-Wno-dev"
+ )
+ cmake-utils_src_configure
}
pkg_preinst() {
- use gnome && gnome2_gconf_savelist
- gnome2_icon_savelist
+ use gnome && gnome2_gconf_savelist
+ gnome2_icon_savelist
}
pkg_postinst() {
- use gnome && gnome2_gconf_install
- gnome2_icon_cache_update
- if use dbus; then
- ewarn "The dbus plugin is known to crash compiz in this version. Disable"
- ewarn "it if you experience crashes when plugins are enabled/disabled."
- fi
+ use gnome && gnome2_gconf_install
+ gnome2_icon_cache_update
+ if use dbus; then
+ ewarn "The dbus plugin is known to crash compiz in this version. Disable"
+ ewarn "it if you experience crashes when plugins are enabled/disabled."
+ fi
}
pkg_prerm() {
- use gnome && gnome2_gconf_uninstall
- gnome2_icon_cache_update
+ use gnome && gnome2_gconf_uninstall
+ gnome2_icon_cache_update
}