summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@slonko.net>2020-02-11 09:24:12 +0100
committerMarcin Deranek <marcin.deranek@slonko.net>2020-02-11 09:24:12 +0100
commit44f102d811dacf6be8f0f84184e2ef8a85fa010b (patch)
tree3779f62cbc8f5f1c544c34f954179a9facb6a133 /x11-wm
parentfb037d9ba13334683b220cec2dafbd983083f82c (diff)
downloadportage-44f102d811dacf6be8f0f84184e2ef8a85fa010b.tar.gz
portage-44f102d811dacf6be8f0f84184e2ef8a85fa010b.tar.bz2
portage-44f102d811dacf6be8f0f84184e2ef8a85fa010b.zip
Fix ebuild
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/compiz/Manifest4
-rw-r--r--x11-wm/compiz/compiz-0.9.13.9999.ebuild8
-rw-r--r--x11-wm/compiz/compiz-9999.ebuild8
3 files changed, 14 insertions, 6 deletions
diff --git a/x11-wm/compiz/Manifest b/x11-wm/compiz/Manifest
index a4c1e28..d423ccb 100644
--- a/x11-wm/compiz/Manifest
+++ b/x11-wm/compiz/Manifest
@@ -1,4 +1,4 @@
AUX access_violation.patch 974 BLAKE2B 9b226e3d7255073bff22448f096fc19f743b97582b2e4de2725c7df84f0895bb63b7eee25d3b82f08090b19b5ea9c1179d57d1eaf994bfabc42e4e04e8f1ec33 SHA512 0d91b71ad9c2646745d91a8a6b3d9228a23dccb3971abf69094ca4f6b3055f92570f01eb6dda62acab8630c05cc9480e846b59bd3b6044a73b31510d72a8f800
AUX fix_pkgconfig_libdir.patch 1155 BLAKE2B 33319182db6d8c46ca0d2f2ced06fd4610c39f59588ff85045a4f83877f25163b0692458e426bf2199fb14e784605ca4844f523b31d1a2d16e201ce8317422c5 SHA512 fb1362ef72864bdcb46d82c042dd688850f496a244b58b9314a2466f93aa79d8a31fc3585a6f08d3d4836c0fdc9d8ce7b4f5a1332bf87c3349a59e4b8011b3c6
-EBUILD compiz-0.9.13.9999.ebuild 3636 BLAKE2B ad8141a2d9d323ca091b122af0c2c8e110563d5c41f99d6b5ea53ce8707f9db639dd5b8705faf4c70bb68ca9f4b37e4429a5700db829d14f9c637b955c1af3d1 SHA512 5ed76b241fae11650c1b78d03853fe1cc7fd64f43529a9f93ca7cfe6cd670ab8074ebe588f258d24fbb5eaf741947fe1ba97e0ff03b8924720e208d0f74d8819
-EBUILD compiz-9999.ebuild 3495 BLAKE2B 6c45cc275e86c7b44197e73fa1cb6a97d4cd81aa3a7ec19869e10947924d8d8de92cd765523ebfed4328be3c9c043605c1f5039503cea1f8ac3ec5ee1b5d0a7a SHA512 517f0ffae69298c4d5afc91e43feb6f57869cafc2d085bdfbdca97d12e4ef5a891265370e268b6e21d2d37632f9ab58a9b2cb4881215fb378b6a174be3ef5af2
+EBUILD compiz-0.9.13.9999.ebuild 3722 BLAKE2B f0c6eb25bce77d59518d80c3784d9bbc839dcc795d88e0e41b4a7d198bae22589a3787562edd4e9683f3ee4973c7b514b94d2f368bb93c58b2254368e12df971 SHA512 943eda4d4bfb95562fed505cbb20ea8590d541686d47f3d42542913f70bf6c9c32ff12ecc2ac3baaa02f1f751d0d4d03138caee9f016f556487899e8217b917a
+EBUILD compiz-9999.ebuild 3581 BLAKE2B abb12c6fa19a1437af0183eba64dfdab63cae4051692ef35e96f16327ba55373548c527ebe5e22b222e1169a6d959635e48b0d9da04ebe1d8b109ce139ceacf6 SHA512 6458efb2b68f9d21863e6ca9523e74478d6597a089fd08fd4a37f64da3bdc701bca63e0667e20ccbe270ad67154a117d28b0138ae86fa7d28925a4e0f425f452
diff --git a/x11-wm/compiz/compiz-0.9.13.9999.ebuild b/x11-wm/compiz/compiz-0.9.13.9999.ebuild
index 5556ab9..b39291d 100644
--- a/x11-wm/compiz/compiz-0.9.13.9999.ebuild
+++ b/x11-wm/compiz/compiz-0.9.13.9999.ebuild
@@ -1,7 +1,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+PYTHON_COMPAT=( python3_{4,5,6} )
inherit cmake-utils eutils gnome2-utils python-single-r1 toolchain-funcs versionator
@@ -23,8 +23,10 @@ LICENSE="GPL-2 LGPL-2.1 MIT"
SLOT="0"
IUSE="+cairo debug dbus fuse gles gnome gtk kde +svg test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
COMMONDEPEND="
+ ${PYTHON_DEPS}
!x11-wm/compiz-fusion
!x11-libs/compiz-bcop
!x11-libs/libcompizconfig
@@ -41,7 +43,9 @@ COMMONDEPEND="
dev-cpp/glibmm
dev-libs/libxml2
dev-libs/libxslt
- dev-python/cython[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_MULTI_USEDEP}]
+ ')
dev-python/pyrex
dev-libs/protobuf
media-libs/libpng
diff --git a/x11-wm/compiz/compiz-9999.ebuild b/x11-wm/compiz/compiz-9999.ebuild
index 3fae3fc..89d7215 100644
--- a/x11-wm/compiz/compiz-9999.ebuild
+++ b/x11-wm/compiz/compiz-9999.ebuild
@@ -1,7 +1,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+PYTHON_COMPAT=( python3_{4,5,6} )
inherit cmake-utils eutils gnome2-utils xdg-utils python-single-r1 toolchain-funcs
@@ -21,8 +21,10 @@ LICENSE="GPL-2 LGPL-2.1 MIT"
SLOT="0"
IUSE="+cairo debug dbus fuse gles gnome gtk kde +svg test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
COMMONDEPEND="
+ ${PYTHON_DEPS}
!x11-wm/compiz-fusion
!x11-libs/compiz-bcop
!x11-libs/libcompizconfig
@@ -39,7 +41,9 @@ COMMONDEPEND="
dev-cpp/glibmm
dev-libs/libxml2
dev-libs/libxslt
- dev-python/cython[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_MULTI_USEDEP}]
+ ')
dev-python/pyrex
dev-libs/protobuf
media-libs/libpng