summaryrefslogtreecommitdiff
path: root/www-apps
diff options
context:
space:
mode:
authorMarcin Deranek <gringo@slonko.net>2016-03-10 08:43:35 +0100
committerMarcin Deranek <gringo@slonko.net>2016-03-10 08:43:35 +0100
commitb909c3390a5db00c2fd2c5d83cede0d9a4c8dfce (patch)
tree5348b6a1d2cbe69493672e287b476b0b9653493a /www-apps
parentdb9b9b5979b4292c814ada22a31b4edd1ba802a7 (diff)
downloadportage-b909c3390a5db00c2fd2c5d83cede0d9a4c8dfce.tar.gz
portage-b909c3390a5db00c2fd2c5d83cede0d9a4c8dfce.tar.bz2
portage-b909c3390a5db00c2fd2c5d83cede0d9a4c8dfce.zip
Added gallery as it got removed from portage
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/gallery/Manifest3
-rw-r--r--www-apps/gallery/files/postinstall-en2.txt27
-rw-r--r--www-apps/gallery/gallery-2.3.2.ebuild61
3 files changed, 91 insertions, 0 deletions
diff --git a/www-apps/gallery/Manifest b/www-apps/gallery/Manifest
new file mode 100644
index 0000000..3a081a5
--- /dev/null
+++ b/www-apps/gallery/Manifest
@@ -0,0 +1,3 @@
+AUX postinstall-en2.txt 912 SHA256 ae1b0727e11518abf12616cd11cb82e6648a026769d9e4854ba6afb6d972c30b SHA512 fc66ccea1ef358b75ef0710a9a6b32e3b363d6588d70b69987041f46f5d04013d36113b3fca426f6a38d4d94e0ccfba637e56f91e41f62c492a8ad1fda64e408 WHIRLPOOL 8dfb2193c1ff6c500581950eb77afc1a41a1a5f1476fb0bb9a9180ea994119e20a5de1a1f7c9e1f5b89618ee130e4429ed1d02cb28acf7525dcd9155f5bec4fa
+DIST gallery-2.3.2-full.tar.gz 14569436 SHA256 810ed73c456a3299ba50d9fcca6725d0654641c078c9d7c278d4875bad2af3fc SHA512 e4ee2007018ecdc6df2cb715798f57a94d2fcf5618a06812d704b45ba398cc9f52465d4ea1d830f2b99611c85d8853d7639059b3761f3b5d77ccc16d1e4ae0ad WHIRLPOOL 4591f8d69d173f01108fec5c21c7bde3f519c44177ef268866031e0c1cc021c452415b73950011e2f1cd46ee314d2741260bcd4ba80bdee56ca5b119a2452975
+EBUILD gallery-2.3.2.ebuild 1829 SHA256 b0fb9883bd861572a4e9cf9ca5c4d3e76ce4db3fa0683a8dfcf550ba9c0523f9 SHA512 a6c835f127a1d09a0dbb80c53c733be1ea83b1b75d5648f9611d8c72721e336362b535aa44d607ff0b1dbed4278183da584652cfa043cce2f99be76810e8d522 WHIRLPOOL 1b050fe539d092d2fcb038b011393219d3af13ed0dc246d1b1e79dc3579f6fa7074dd9b27d6bfbf5a553064ce40a7fadbea8b5b1788acbdf568c2441955fc373
diff --git a/www-apps/gallery/files/postinstall-en2.txt b/www-apps/gallery/files/postinstall-en2.txt
new file mode 100644
index 0000000..bcc9770
--- /dev/null
+++ b/www-apps/gallery/files/postinstall-en2.txt
@@ -0,0 +1,27 @@
+For new installations:
+
+1. Create a directory to share photos and make it writeable by the web server.
+
+2. Create a database for Gallery 2.
+ MySQL: mysqladmin -uroot create gallery2
+ mysql gallery2 -uroot -e"GRANT ALL ON gallery2.* TO
+ username@localhost IDENTIFIED BY 'password'"
+ PostgreSQL: createdb gallery2 -E UNICODE
+ if that doesn't work, try
+ createdb gallery2 -E SQL_ASCII
+ if that doesn't work either, try
+ createdb gallery2
+
+3. Now browse to http://${VHOST_HOSTNAME}/${VHOST_APPDIR}/install
+
+NOTE: The installer may complain that FfmpegToolkit.class has been modified.
+This is normal, as we patch it to fix a bug with newer versions of ffmpeg.
+
+For upgrades:
+
+1. Copy over your config.php and the g2data directory.
+
+2. If you are using a PHP accelerator, flush its cache.
+
+3. Browse to http://${VHOST_HOSTNAME}/${VHOST_APPDIR}/upgrade and follow the
+ instructions.
diff --git a/www-apps/gallery/gallery-2.3.2.ebuild b/www-apps/gallery/gallery-2.3.2.ebuild
new file mode 100644
index 0000000..ac2b18d
--- /dev/null
+++ b/www-apps/gallery/gallery-2.3.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/gallery/gallery-2.3.2.ebuild,v 1.8 2015/07/05 22:06:42 blueness Exp $
+
+EAPI="5"
+
+inherit webapp eutils depend.php confutils
+
+DESCRIPTION="Web based (PHP Script) photo album viewer/creator"
+HOMEPAGE="http://galleryproject.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-full.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 hppa ppc ppc64 x86"
+IUSE="ffmpeg +gd imagemagick +mysql netpbm postgres raw sqlite unzip zip"
+
+RDEPEND="raw? ( media-gfx/dcraw )
+ ffmpeg? ( virtual/ffmpeg )
+ imagemagick? ( || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] ) )
+ netpbm? ( media-libs/netpbm media-gfx/jhead )
+ unzip? ( app-arch/unzip )
+ zip? ( app-arch/zip )
+ sqlite? ( dev-lang/php[pdo] dev-lang/php[sqlite] )
+ mysql? ( || ( dev-lang/php[mysql] dev-lang/php[mysqli] ) )
+ dev-lang/php[session,postgres?,gd?]
+ virtual/httpd-php"
+
+S=${WORKDIR}/${PN}2
+
+need_httpd_cgi
+
+pkg_setup() {
+ webapp_pkg_setup
+ confutils_require_any gd imagemagick netpbm
+ confutils_require_any mysql postgres sqlite
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dohtml README.html
+ rm README.html LICENSE
+ sed -i -e "/^LICENSE\>/d" -e "/^README\.html\>/d" MANIFEST
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_postinst_txt en "${FILESDIR}/postinstall-en2.txt"
+ webapp_src_install
+}
+
+pkg_postinst() {
+ elog "You are strongly encouraged to back up your database"
+ elog "and the g2data directory, as upgrading may make"
+ elog "irreversible changes to both."
+ elog
+ elog "g2data dir: cp -Rf /path/to/g2data/ /path/to/backup"
+ elog "mysql: mysqldump --opt -u username -h hostname -p database > /path/to/backup.sql"
+ elog "postgres: pg_dump -h hostname --format=t database > /path/to/backup.sql"
+ webapp_pkg_postinst
+}