summaryrefslogtreecommitdiff
path: root/www-apps
diff options
context:
space:
mode:
authorMarcin Deranek <gringo@slonko.net>2016-04-24 09:49:48 +0200
committerMarcin Deranek <gringo@slonko.net>2016-04-24 09:49:48 +0200
commit3e39a711e3a2171f5f69747b8520ea9bdfad7508 (patch)
tree9c30fdd6899e0485b817278ca187d2f01fa4dd90 /www-apps
parentbbbdf2b6d0a1c1a386558182ee4da6beee46ef37 (diff)
downloadportage-3e39a711e3a2171f5f69747b8520ea9bdfad7508.tar.gz
portage-3e39a711e3a2171f5f69747b8520ea9bdfad7508.tar.bz2
portage-3e39a711e3a2171f5f69747b8520ea9bdfad7508.zip
Add pydio
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/pydio/Manifest2
-rw-r--r--www-apps/pydio/pydio-6.2.2.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/www-apps/pydio/Manifest b/www-apps/pydio/Manifest
new file mode 100644
index 0000000..59459ec
--- /dev/null
+++ b/www-apps/pydio/Manifest
@@ -0,0 +1,2 @@
+DIST pydio-6.2.2.tar.gz 15735734 SHA256 f30a60926ce73737668d9bb64b54564f1dd2de34529466fd4770614928a33c99 SHA512 bb6ae645cb81dcce3c2d747b5fe38f4757cd3ce805662799f3dcb82940ef96ff069fc524a121667c72a1349fce6e0ea950d618d87e3e5638a6d98773764acea7 WHIRLPOOL e100bbb6d5e9af4fd7b11b2aa860dd410b7128213cacacbef515308e3e1550a2ceee163f0acf6f08d8acd6f53d4b91f123826b5eecb9eb72691f6f7a23936988
+EBUILD pydio-6.2.2.ebuild 1384 SHA256 06550c2ea21020bdc2148b04aba20670d4fc584c7815d8a2318591f1b14e2b6b SHA512 3e7688fc5c24f0fe16eb34d194f377c2b83ca15c674d35a32dc8c65110fdb8c761337101533044a0ba8c20c2218f8f03ee922ac8fa8ab07f8df5b30c3fca44bf WHIRLPOOL 8f478f3bb5f4062c0eaa923bc26dbafede447d5a71c8174ebb199684710aec69a2178a7895b32aa4736c10f0a4b0542e0db62b96e50133ff9d4c0275146daef0
diff --git a/www-apps/pydio/pydio-6.2.2.ebuild b/www-apps/pydio/pydio-6.2.2.ebuild
new file mode 100644
index 0000000..b0db8cc
--- /dev/null
+++ b/www-apps/pydio/pydio-6.2.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit webapp depend.php
+
+DESCRIPTION="File sharing platform similar to dropbox"
+HOMEPAGE="https://pyd.io/"
+SRC_URI="http://sourceforge.net/projects/ajaxplorer/files/${PN}/stable-channel/${PV}/${PN}-core-${PV}.tar.gz/download -> ${P}.tar.gz"
+RESTRICTION="mirror"
+
+LICENSE="AGPL-3"
+KEYWORDS="~amd64 ~x86"
+IUSE="+webdav"
+
+DEPEND="webdav? ( dev-php/PEAR-HTTP_WebDAV_Client )"
+RDEPEND="${DEPEND}"
+
+need_php_httpd
+
+S="${WORKDIR}/${PN}-core-${PV}"
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r "${S}"/*
+
+ insinto "${MY_HTDOCSDIR}"/upgrade-scripts
+ doins "${FILESDIR}"/*.php
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/data
+
+ webapp_configfile "${MY_HTDOCSDIR}/base.conf.php"
+ webapp_configfile "${MY_HTDOCSDIR}/conf/bootstrap_"{conf,context,repositories}".php"
+ webapp_configfile "${MY_HTDOCSDIR}/conf/mime.types"
+ webapp_configfile "${MY_HTDOCSDIR}/conf/extensions.conf.php"
+
+ # FIXME: does not fit eclass design
+ #webapp_sqlscript mysql "${MY_HTDOCSDIR}"/plugins/*/create.mysql
+ #webapp_sqlscript postgres "${MY_HTDOCSDIR}"/plugins/*/create.pgsql
+
+ webapp_sqlscript mysql "${FILESDIR}"/6.2.0.mysql 6.0
+ webapp_sqlscript postgres "${FILESDIR}"/6.2.0.pgsql 6.0
+
+ webapp_postinst_txt en "${FILESDIR}"/postinst.en.txt
+
+ webapp_src_install
+}