summaryrefslogtreecommitdiff
path: root/www-apps
diff options
context:
space:
mode:
authorMarcin Deranek <gringo@slonko.net>2017-08-06 15:00:05 +0200
committerMarcin Deranek <gringo@slonko.net>2017-08-06 15:00:05 +0200
commit16327e331e3ba524b59c19dec3e7f8b20dfd9854 (patch)
treea3a8b80fa8f3f7766cbdf1b3ec048d102a90d751 /www-apps
parent800a4484245dfa0f7ff7f4ce8e079b27af98bbce (diff)
downloadportage-16327e331e3ba524b59c19dec3e7f8b20dfd9854.tar.gz
portage-16327e331e3ba524b59c19dec3e7f8b20dfd9854.tar.bz2
portage-16327e331e3ba524b59c19dec3e7f8b20dfd9854.zip
Version bump
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/joomla/joomla-3.7.4.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/www-apps/joomla/joomla-3.7.4.ebuild b/www-apps/joomla/joomla-3.7.4.ebuild
new file mode 100644
index 0000000..2e312f4
--- /dev/null
+++ b/www-apps/joomla/joomla-3.7.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit webapp versionator
+
+MY_PV=$(replace_version_separator '_' '-')
+
+DESCRIPTION="A powerful Open Source Content Management System"
+HOMEPAGE="http://www.joomla.org/"
+M_PN="Joomla_${MY_PV}-Stable-Full_Package"
+SRC_URI="https://github.com/${PN}/${PN}-cms/releases/download/${MY_PV}/${M_PN}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+S="${WORKDIR}"
+need_httpd_cgi
+
+RDEPEND=">=dev-lang/php-5.3.10[json,zlib,xml]
+ virtual/httpd-php
+ || ( dev-lang/php[mysql] dev-lang/php[postgres] )"
+
+src_install () {
+ webapp_src_preinst
+
+ touch configuration.php
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ local files=" administrator/cache administrator/components
+ administrator/language administrator/language/en-GB
+ administrator/manifests/packages
+ administrator/modules administrator/templates cache components images installation
+ images/banners language language/en-GB media modules plugins
+ plugins/authentication plugins/content plugins/editors plugins/editors-xtd
+ plugins/search plugins/system plugins/user plugins tmp templates"
+
+ for file in ${files}; do
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/${file}
+ done
+
+ webapp_configfile "${MY_HTDOCSDIR}"/configuration.php
+ webapp_serverowned "${MY_HTDOCSDIR}"/configuration.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_postinst_txt sv "${FILESDIR}"/postinstall-sv.txt
+ webapp_src_install
+}