summaryrefslogtreecommitdiff
path: root/sys-kernel
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@slonko.net>2017-09-06 19:30:09 +0200
committerMarcin Deranek <marcin.deranek@slonko.net>2017-09-06 19:30:16 +0200
commit953889455e674d61de844862eacba3ef74e576ab (patch)
tree98b353dde11ff84fddce701aa03fafb65e4a1f35 /sys-kernel
parenta9257d82777b3858ab33ac0cfe54e900e87b09dd (diff)
downloadportage-953889455e674d61de844862eacba3ef74e576ab.tar.gz
portage-953889455e674d61de844862eacba3ef74e576ab.tar.bz2
portage-953889455e674d61de844862eacba3ef74e576ab.zip
Add grsecurity kernel
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/grsecurity-sources/Manifest3
-rw-r--r--sys-kernel/grsecurity-sources/grsecurity-sources-4.9.44.ebuild39
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-kernel/grsecurity-sources/Manifest b/sys-kernel/grsecurity-sources/Manifest
new file mode 100644
index 0000000..9123c53
--- /dev/null
+++ b/sys-kernel/grsecurity-sources/Manifest
@@ -0,0 +1,3 @@
+DIST grsecurity-sources-extras-4.9.44.tar.xz 2643884 SHA256 2c8ea5db8c7b0686189fd358fda2237ba1f3a239b31ac8c8f38a9fe81f5533bb SHA512 ef34a5ae6bd99763fe812a4342107ff5032af2b41b560d43279562e8511c2b36da06e30ccc599e23160a95a3833f93d30133e6d9a98cccbb5e6fa028a5e7bd09 WHIRLPOOL 7b14947feb0f0446baa9489a8dd215815414f88614d18848e51a2fc62234df7290fb2513fe87b7907d07aa6d2cea8a3d5f2253b1b0a7b75a9f2dd09d02b7847c
+DIST linux-4.9.tar.xz 93192404 SHA256 029098dcffab74875e086ae970e3828456838da6e0ba22ce3f64ef764f3d7f1a SHA512 bf67ff812cc3cb7e5059e82cc5db0d9a7c5637f7ed9a42e4730c715bf7047c81ed3a571225f92a33ef0b6d65f35595bc32d773356646df2627da55e9bc7f1f1a WHIRLPOOL 072505b29972ad120eb25a074217847c9c2813416c4903e605a0433574f5f87616dbea0b1454e4b19acc48107f11274b682958b1d773373156e99f8163e6606a
+EBUILD grsecurity-sources-4.9.44.ebuild 1175 SHA256 34b5670cbd765212f3bb36fdb6c8e5d05909664f5114b124d51ed352c5a5dfdd SHA512 f1614b5d2ba6c6efe3e49c74b374db8d25e5952ae736c1c54906cc035298a38dcfc71c51d2b9b2d7fc67a8e37a84d7abde0b215461d6aa1f53ed578601f4a5be WHIRLPOOL 6da24e3a8348c3d7e9eef64a0718d496bcc7d1cfb9eb4937627665bc5c0c2a067fb22a237b90922f0eb5ccd4a14304f2d0cedcb03e8edba478053987184165e6
diff --git a/sys-kernel/grsecurity-sources/grsecurity-sources-4.9.44.ebuild b/sys-kernel/grsecurity-sources/grsecurity-sources-4.9.44.ebuild
new file mode 100644
index 0000000..aa63e28
--- /dev/null
+++ b/sys-kernel/grsecurity-sources/grsecurity-sources-4.9.44.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# See https://blogs.gentoo.org/ago/2017/08/21/sys-kernel-grsecurity-sources-available
+
+EAPI="6"
+
+ETYPE="sources"
+K_GENPATCHES_VER="not-empty" # Set to not-empty to avoid the useless download of patch-*.xz
+
+inherit kernel-2
+detect_version
+detect_arch
+
+GRSECURITY_URI="https://dev.gentoo.org/~ago/distfiles/${PN}/${PN}-extras-${PV}.tar.xz"
+SRC_URI="${KERNEL_URI} ${GRSECURITY_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/${PN}-extras-${PV}.tar.xz"
+
+DESCRIPTION="Unofficial port of the last public grsecurity patch plus Gentoo patchset"
+HOMEPAGE="https://github.com/minipli/linux-unofficial_grsec"
+IUSE="deblob"
+KEYWORDS="-* ~amd64"
+RDEPEND=">=sys-devel/gcc-4.5"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-3.1*"
+
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}