summaryrefslogtreecommitdiff
path: root/net-print
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@slonko.net>2019-01-25 22:05:23 +0100
committerMarcin Deranek <marcin.deranek@slonko.net>2019-01-25 22:05:33 +0100
commit3520beb37e9ef09e1de4dca04603f710a764f922 (patch)
treeb1a5d2a8edfcaebfd2de26f822d0c67b7e47f094 /net-print
parentd5c52c582ee69a0e268bf2a1edd992c2f2249ffb (diff)
downloadportage-3520beb37e9ef09e1de4dca04603f710a764f922.tar.gz
portage-3520beb37e9ef09e1de4dca04603f710a764f922.tar.bz2
portage-3520beb37e9ef09e1de4dca04603f710a764f922.zip
Latest cnijfilter2 from Canon
Diffstat (limited to 'net-print')
-rw-r--r--net-print/cnijfilter2/Manifest3
-rw-r--r--net-print/cnijfilter2/cnijfilter2-5.70.ebuild64
-rw-r--r--net-print/cnijfilter2/files/cnijfilter2-5.20-gentoo.patch50
3 files changed, 117 insertions, 0 deletions
diff --git a/net-print/cnijfilter2/Manifest b/net-print/cnijfilter2/Manifest
new file mode 100644
index 0000000..5d7d634
--- /dev/null
+++ b/net-print/cnijfilter2/Manifest
@@ -0,0 +1,3 @@
+AUX cnijfilter2-5.20-gentoo.patch 1535 BLAKE2B c3861e039d0ecce6f1940c1f998ce23ab2834f18a7394c82070e83d7de4d7860869775d5e017a8e26999f3798090bcffab699916263953afbc52a24f39b3bb23 SHA512 29458eabdfe3f7c66b47ddbd490c741b78a3cb9b375be1769e65d2240e732fc184005de226eed8985f77aa153c00c39463d9fce41ba79a439874ebb031acb70d
+DIST cnijfilter2-source-5.70-1.tar.gz 1366033 BLAKE2B 0d03c4c4f4bc00ea91cc46db6554252997242dcc98ee65fe856528848843cdd6d2195e3839d8dad71f1fc722cfbb2e65730020665d9095d0a93900840659477d SHA512 3d9afe4ca6b042015898f4fc08d991a4af2c55010c9d98807a12dade01d2655f74b7e4896abeb933c93faeca954bcfdadfd6e359ee8efe5952623fc635500729
+EBUILD cnijfilter2-5.70.ebuild 1510 BLAKE2B a878a3dde7e19ffd9f4396c99d402c3943415d4eea26ea57ab77a5cc12f7550cd1ecaf5ad76d35cde424f07514cba7c05158b8f9aa4f4cd88404ad8b46dbd45e SHA512 14c14e2342b572cfbdd00c8f67b9ef781785158e71450f78e30ba260a4d1f552da977f0f652b4f56b27f2de44cd3f9d7384936c8d0c6080a573f169ae0675172
diff --git a/net-print/cnijfilter2/cnijfilter2-5.70.ebuild b/net-print/cnijfilter2/cnijfilter2-5.70.ebuild
new file mode 100644
index 0000000..0da124e
--- /dev/null
+++ b/net-print/cnijfilter2/cnijfilter2-5.70.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+MY_P="${PN}-source-${PV}-1"
+
+DESCRIPTION="IJ Printer Driver"
+HOMEPAGE="https://www.canon.it/"
+SRC_URI="http://gdlp01.c-wss.com/gds/0/0100009930/01/${MY_P}.tar.gz"
+
+LICENSE="Canon-IJ"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="virtual/libusb:1
+ dev-libs/libxml2
+ net-print/cups"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+PATCHES=( "${FILESDIR}"/${PN}-5.20-gentoo.patch )
+
+src_prepare() {
+ default
+ DIRS="cmdtocanonij2 cnijbe2 lgmon3 rastertocanonij tocanonij tocnpwg"
+ LIBDIR=com/libs_bin$(usex amd64 64 32)
+ for d in ${DIRS}; do
+ mv "${d}"/configure.{in,ac} || die
+ done
+ echo "AC_INIT([${PN}], [${PV}])" >> configure.ac
+ echo "AM_INIT_AUTOMAKE" >> configure.ac
+ echo "AC_CONFIG_SUBDIRS([${DIRS}])" >> configure.ac
+ echo "AC_CONFIG_FILES([Makefile])" >> configure.ac
+ echo "AC_OUTPUT()" >> configure.ac
+ echo "SUBDIRS= ${DIRS}" >> Makefile.am
+ sed -i \
+ -e "/^CFLAGS/d" \
+ */configure.ac || die
+ eautoreconf
+ cd ${LIBDIR}
+ rm libcn*.so || die
+ ln -sf libcnbpcnclapicom2.so.5.0.0 libcnbpcnclapicom2.so || die
+ ln -sf libcnbpnet20.so.1.0.0 libcnbpnet20.so || die
+ ln -sf libcnbpnet30.so.1.0.0 libcnbpnet30.so || die
+ ln -sf libcnnet2.so.1.2.4 libcnnet2.so || die
+
+ cd -
+}
+
+src_configure() {
+ LDFLAGS="-L"${S}"/${LIBDIR}" econf --enable-progpath="${EPREFIX}/usr/bin"
+}
+
+src_install() {
+ default
+ insinto /usr/share/ppd/cupsfilters
+ doins ppd/*ppd
+ dolib.so ${LIBDIR}/*
+}
diff --git a/net-print/cnijfilter2/files/cnijfilter2-5.20-gentoo.patch b/net-print/cnijfilter2/files/cnijfilter2-5.20-gentoo.patch
new file mode 100644
index 0000000..be94179
--- /dev/null
+++ b/net-print/cnijfilter2/files/cnijfilter2-5.20-gentoo.patch
@@ -0,0 +1,50 @@
+--- a/cmdtocanonij2/filter/Makefile.am.old 2018-01-14 18:14:20.645473030 +0100
++++ b/cmdtocanonij2/filter/Makefile.am 2018-01-14 18:14:36.078219959 +0100
+@@ -1,4 +1,4 @@
+-filterdir=$(libdir)/cups/filter
++filterdir=$(libexecdir)/cups/filter
+
+ filter_PROGRAMS= cmdtocanonij2
+
+--- a/cnijbe2/src/Makefile.am.old 2018-01-14 19:25:48.823470121 +0100
++++ b/cnijbe2/src/Makefile.am 2018-01-14 19:25:59.316275741 +0100
+@@ -1,6 +1,6 @@
+ ## Process this file with automake to produce Makefile.in
+
+-backend_bindir = /usr/lib/cups/backend
++backend_bindir = $(libexecdir)/cups/backend
+ backend_bin_PROGRAMS = cnijbe2
+ transform =
+
+--- a/rastertocanonij/src/Makefile.am.old 2018-01-14 21:31:33.053307218 +0100
++++ b/rastertocanonij/src/Makefile.am 2018-01-14 21:31:41.106166479 +0100
+@@ -1,4 +1,4 @@
+-filterdir=$(libdir)/cups/filter
++filterdir=$(libexecdir)/cups/filter
+
+ filter_PROGRAMS= rastertocanonij
+
+--- a/tocanonij/src/Makefile.am.old 2018-01-15 22:38:14.236460663 +0100
++++ b/tocanonij/src/Makefile.am 2018-01-15 22:38:39.184018933 +0100
+@@ -1,7 +1,8 @@
+ INCLUDES = \
+ -I$(top_srcdir)/include/cncl
+
+-bin_PROGRAMS= tocanonij
++filterdir=$(libexecdir)/cups/filter
++filter_PROGRAMS= tocanonij
+
+ tocanonij_SOURCES= \
+ main.c
+--- a/tocnpwg/src/Makefile.am.old 2018-01-15 22:42:43.759703863 +0100
++++ b/tocnpwg/src/Makefile.am 2018-01-15 22:43:10.442232986 +0100
+@@ -2,7 +2,8 @@
+ INCLUDES = \
+ @XML_2_CFLAGS@
+
+-bin_PROGRAMS= tocnpwg
++filterdir=$(libexecdir)/cups/filter
++filter_PROGRAMS= tocnpwg
+
+ tocnpwg_SOURCES= \
+ main.c mkpset.c