summaryrefslogtreecommitdiff
path: root/net-mail
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@slonko.net>2020-03-09 22:57:12 +0100
committerMarcin Deranek <marcin.deranek@slonko.net>2020-03-09 22:57:12 +0100
commita4653769e2a57360b980fd17ad9781d06da90d24 (patch)
tree55687984fab7907af34053ebc9fb390929a45f8b /net-mail
parentd74c629e48ade7b63a9cffeba2b1b53a9d2c298d (diff)
downloadportage-a4653769e2a57360b980fd17ad9781d06da90d24.tar.gz
portage-a4653769e2a57360b980fd17ad9781d06da90d24.tar.bz2
portage-a4653769e2a57360b980fd17ad9781d06da90d24.zip
More cleanups and fixes
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/sympa/Manifest2
-rw-r--r--net-mail/sympa/sympa-6.2.48.ebuild28
2 files changed, 10 insertions, 20 deletions
diff --git a/net-mail/sympa/Manifest b/net-mail/sympa/Manifest
index ba612f9..3b41f79 100644
--- a/net-mail/sympa/Manifest
+++ b/net-mail/sympa/Manifest
@@ -5,4 +5,4 @@ AUX sympa-lighttpd.conf 372 BLAKE2B 701e0bc7ed328257a62d29eb5899da255a5102e8fc1c
AUX sympa-lighttpd_soap.conf 382 BLAKE2B 08456e6603a4a2f960a818c5ab5374d03c15e5cc30aae83ad6602758d7cad857fd0b2a1995f23c37b17f3046a2f45f57e14f9b5cf7742fde0b4c23c86798d5b2 SHA512 1aac44ca4c410d90e384ac092cfbb2ead8a144ed472998266ccc9b1411e6ce6d4c02edbf46496c14585c65cfbf23cf8276901df2d54895bdf4edd3cecf447f2d
AUX sympa-nginx.conf 252 BLAKE2B 51471cdc0151a10d86b396bb7d3ecca51508d53fbcce91804c2ffcfefd6ee9170502d2cc36519eb66570371150fafa81ae7ed991d38ba901e1c4248f806d06e5 SHA512 076900022f1d6c03e26301ed15514dc922a9ba9718c8a344722ad755c5caf0277daae944959f061445f58ef163d6d243670fb97b92f06e6370a1f8621762221f
DIST sympa-6.2.48.tar.gz 12768937 BLAKE2B 188189eac2712bdab4673ca09e4a4c37d035906524a0a73d7eac74e517906b3e63c588af4636c31c3dd861850fa0e452474ff8873f454d3dfad650c05b99afb0 SHA512 b1ff034fc9a69edae266741e3b868555040bc1c4cdba9bae901729cd23b3f310895d0a9a5fe2119373880f1b65c25cd14e6753d93ad4ff15adf377f51cc25719
-EBUILD sympa-6.2.48.ebuild 8133 BLAKE2B 43cd7aa66232550ba70452cc43876da9f6ab7459ab0162d356de0def262649b55a5491aaaf00a55e503b364ceb25362ce2f4bdfd012cbcee212010e8a49c2dea SHA512 192d61d2f187c678531042cb88d391f560973a01681c2dd37eaee4370ae3a8ccaf105b21fd88b1dec48713712942dfda95b28669a99c12aee3dff72f2a9b2500
+EBUILD sympa-6.2.48.ebuild 7884 BLAKE2B b78754a91484cac8f435772d2b4e10f9d0401a5dfb5d343aa19ae3241dd30a277685f843c59cb27cca612f33722b24c8c61ce6e6a16b493088c6a80ee4f46afa SHA512 5f5980bee399e142cc2793a8f5d10f1f221fc06fcbf2dfd0b239833057d26f9d670c2828f47de548d51bc0d37ee20785b3513eca0dc34d45604963ec217d0392
diff --git a/net-mail/sympa/sympa-6.2.48.ebuild b/net-mail/sympa/sympa-6.2.48.ebuild
index 652623f..238f333 100644
--- a/net-mail/sympa/sympa-6.2.48.ebuild
+++ b/net-mail/sympa/sympa-6.2.48.ebuild
@@ -1,13 +1,12 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-EAPI=5
+EAPI=7
-inherit eutils user multilib autotools versionator
+inherit eutils user multilib autotools
-SYMPA_VERSION="$(get_version_component_range 1-2)"
-SYMPA_RELEASE="$(get_version_component_range 3-)"
+SYMPA_VERSION="$(ver_cut 1-2)"
+SYMPA_RELEASE="$(ver_cut 3-)"
if [[ ${SYMPA_VERSION} == "9999" ]] ; then
# Development version
@@ -25,7 +24,7 @@ else
fi
DESCRIPTION="A feature-rich open source mailing list software"
-HOMEPAGE="http://www.sympa.org/"
+HOMEPAGE="https://www.sympa.org/"
SLOT="0"
LICENSE="GPL-2"
@@ -33,7 +32,7 @@ KEYWORDS="~amd64 ~x86"
IUSE="clamav -compat dkim fastcgi ldap mysql nls postgres soap sqlite ssl"
REQUIRED_USE="|| ( mysql postgres sqlite )"
-# See http://www.sympa.org/manual/installing-sympa#required_cpan_modules
+# See https://www.sympa.org/manual/installing-sympa#required_cpan_modules
RDEPEND="
>=dev-lang/perl-5.8
>=dev-perl/CGI-3.51
@@ -103,16 +102,7 @@ pkg_setup() {
enewuser ${SYMPA_USER} -1 -1 -1 ${SYMPA_GROUP}
}
-src_unpack() {
- if [[ ${SYMPA_VERSION} == "9999" ]] ; then
- subversion_src_unpack
- elif [[ ${SYMPA_RELEASE} == "9999" ]] ; then
- subversion_src_unpack
- else
- unpack ${A}
- cd "${S}"
- fi
- cd "${S}"
+src_prepare() {
# Override defaults for certain options, so
# Sympa won't complain about conflicting paths
sed -i -e "/'queuebounce'/,/}/ s|'/bounce'|'/qbounce'|" src/lib/Sympa/ConfDef.pm
@@ -243,7 +233,7 @@ pkg_postinst() {
elog
elog "The Sympa web interface needs to be setup in your webserver."
elog "For more information please consult Sympa documentation at"
- elog "http://www.sympa.org/manual/web-interface#web_server_setup"
+ elog "https://www.sympa.org/manual/web-interface#web_server_setup"
elog "Sample configs are installed in /usr/share/doc/${P}"
elog