summaryrefslogtreecommitdiff
path: root/games-fps
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2021-08-25 21:25:00 +0200
committerMarcin Deranek <marcin.deranek@booking.com>2021-08-25 21:25:00 +0200
commit9e8164ffafeb0c23ffe11a4058caff7100bfb0e3 (patch)
treed626de641c67fa775c8ce7d44feb7f07c178892d /games-fps
parentf47a65c2d093a0670244153985f1e74e879c6142 (diff)
downloadportage-9e8164ffafeb0c23ffe11a4058caff7100bfb0e3.tar.gz
portage-9e8164ffafeb0c23ffe11a4058caff7100bfb0e3.tar.bz2
portage-9e8164ffafeb0c23ffe11a4058caff7100bfb0e3.zip
Address various Q/A issues with armyops ebuild
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/armyops/Manifest2
-rw-r--r--games-fps/armyops/armyops-250.ebuild29
2 files changed, 22 insertions, 9 deletions
diff --git a/games-fps/armyops/Manifest b/games-fps/armyops/Manifest
index 4d8e105..c6b0897 100644
--- a/games-fps/armyops/Manifest
+++ b/games-fps/armyops/Manifest
@@ -1,3 +1,3 @@
DIST armyops250-linux.run 813453963 BLAKE2B 18bcb681d63981fef223b2705e504bd59b921bd5430c8689e528f4e1e5ccf623f22045ce554d75bdff21bfd449f4736cd16a967b6b1d0efc8052352dc61b7e5c SHA512 ed4295c0d4756ae9df76b78620922752e9edeaf41b3d056d9d186b8f594288b3c637223959073d3a1ba4011f6b50db4b4b43d56e6d63880e40c94e3fdfccd215
-EBUILD armyops-250.ebuild 1433 BLAKE2B 9c59dc4b6a8fa31fe738548c2535baa2e295857132f25d826fa58538f946a5c5f57a102f5ada73e3795f0cd31a75cdedc6f01920194650bd4c832f66d1572bd2 SHA512 7faf20c07ed1f1421ee574631babdc90a04cc1da0498c199729d4a16bb134512309246d767441d8188ca9f4175d0637118b8b51ebfbcdde7910ea6966f764306
+EBUILD armyops-250.ebuild 1824 BLAKE2B a8d791efe97a0b2cb28a187576a91ed9b63e9c2bc038eaecbefab09da2a372885ed7f2227c25220684baed084e11c9f82ea38ad77d059bf43f2a65c7bb779e25 SHA512 8451c076fe30e70f0f157ed5c6c027c048b0605b8f0c8cbcff0da636879014aa0d55e333ac863348ead836466126095911dd8c5fec9723cbe5297645b535c927
MISC metadata.xml 270 BLAKE2B 354405e30bba4ff898f7757cd04aaf1dee3ba1fcba299a30e29e81bf1008e1e3e0d7e1949b2eda88cf6e67f918364961cf8f7dd3d15d9a7cbb91ad6925526746 SHA512 42f10d91b3245afecee92dfb408e53a8d0d311f7764940d654947a1328e795627ec50f7ba98c6ef12d956d9fa80eba259432b7ff8663f7c6a621e6f4f51c1ba4
diff --git a/games-fps/armyops/armyops-250.ebuild b/games-fps/armyops/armyops-250.ebuild
index 0319757..adc3613 100644
--- a/games-fps/armyops/armyops-250.ebuild
+++ b/games-fps/armyops/armyops-250.ebuild
@@ -11,14 +11,29 @@ SRC_URI="mirror://sourceforge/distrobuild/${PN}${PV}-linux.run"
LICENSE="Army-EULA"
SLOT="0"
-KEYWORDS="amd64 x86"
-RESTRICT="mirror strip"
-IUSE="opengl"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="bindist mirror strip"
+IUSE=""
-RDEPEND="sys-libs/glibc"
+RDEPEND="
+ amd64? ( sys-libs/glibc[multilib] )
+ app-crypt/libmd[abi_x86_32(-)]
+ dev-libs/libbsd[abi_x86_32(-)]
+ sys-libs/glibc
+ sys-libs/libstdc++-v3:5
+ virtual/opengl[abi_x86_32(-)]
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXdmcp[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ x11-libs/libxcb[abi_x86_32(-)]
+"
S=${WORKDIR}
+dir=opt/${PN}
+
+QA_PREBUILT="${dir}/System/*-bin ${dir}/System/*.so ${dir}/System/libSDL-1.2.so.0 ${dir}/System/pb/*.so"
+
pre_build_checks() {
CHECKREQS_DISK_BUILD="3G"
check-reqs_pkg_setup
@@ -55,8 +70,6 @@ src_install() {
doexe bin/armyops || die "doexe failed"
fperms ug+x "${dir}"/System/pb/pbweb.x86
- if use opengl ; then
- make_wrapper armyops ./armyops "${dir}" "${dir}"
- make_desktop_entry armyops "America's Army" armyops.xpm
- fi
+ make_wrapper armyops ./armyops "${dir}" "${dir}"
+ make_desktop_entry armyops "America's Army" armyops.xpm
}