summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2020-12-03 11:15:38 +0100
committerMarcin Deranek <marcin.deranek@booking.com>2020-12-03 11:15:38 +0100
commitc811821f5e79e903f18e6d6425cef9f95ad79854 (patch)
tree6fc1724c70f84b63a8a54d2388a256c259f39034
parent6923b3d0e2997220f62d6a0d609d4ce9cf52a9cb (diff)
downloadportage-c811821f5e79e903f18e6d6425cef9f95ad79854.tar.gz
portage-c811821f5e79e903f18e6d6425cef9f95ad79854.tar.bz2
portage-c811821f5e79e903f18e6d6425cef9f95ad79854.zip
ALready upstream
-rw-r--r--app-misc/solaar/Manifest1
-rw-r--r--app-misc/solaar/solaar-9999.ebuild56
2 files changed, 0 insertions, 57 deletions
diff --git a/app-misc/solaar/Manifest b/app-misc/solaar/Manifest
deleted file mode 100644
index b8b77a0..0000000
--- a/app-misc/solaar/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-EBUILD solaar-9999.ebuild 1276 BLAKE2B 19d95ce91ad782ccd956b6fa38508c14d6bbc35d4757eb64a06a3dc618b9da372f3170872f9af3f48b5d5a413dd8f6db282f150c037abd84b2a43de4178a07a6 SHA512 ff1bcda8363d52eb4adc342a305ba85b626320f3be5c47265d4c333242d06b7a8d55dfd4860e08cdda4941d4fce5f1b7c8b5b3cfaf619979f3885d65ecf68c27
diff --git a/app-misc/solaar/solaar-9999.ebuild b/app-misc/solaar/solaar-9999.ebuild
deleted file mode 100644
index 8ccec31..0000000
--- a/app-misc/solaar/solaar-9999.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit linux-info udev xdg distutils-r1
-
-if [[ ${PV} == *9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/pwr-Solaar/Solaar"
- EGIT_CHECKOUT_DIR="${WORKDIR}/Solaar-${PV}"
-else
- SRC_URI="https://github.com/pwr-Solaar/Solaar/archive/${PV}.tar.gz -> ${P}.tar.gz"
-fi
-
-DESCRIPTION="A Linux device manager for Logitech's Unifying Receiver peripherals"
-HOMEPAGE="https://pwr-solaar.github.io/Solaar/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm x86"
-IUSE="doc"
-
-RDEPEND="
- acct-group/plugdev
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- >=dev-python/pyudev-0.13[${PYTHON_USEDEP}]
- x11-libs/gtk+:3[introspection]"
-
-S="${WORKDIR}"/Solaar-${PV}
-
-CONFIG_CHECK="~HID_LOGITECH_DJ ~HIDRAW"
-
-python_prepare_all() {
- # don't autostart (bug #494608)
- sed -i '/yield autostart_path/d' setup.py || die
-
- # grant plugdev group rw access
- sed -i 's/#MODE=/MODE=/' rules.d/42-logitech-unify-permissions.rules || die
-
- distutils-r1_python_prepare_all
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- udev_dorules rules.d/*.rules
-
- dodoc docs/devices.md
- if use doc; then
- dodoc -r docs/*
- fi
-}