summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2023-05-28 00:39:23 +0200
committerMarcin Deranek <marcin.deranek@booking.com>2023-05-28 00:39:23 +0200
commit6e86c33027196bb8b753d4a5a6a0d84fe3cd0e96 (patch)
tree722a4af8f7859239a86d792379dc46ae5a461073
parente1092697bb96afe6859db264e702515dc88d68eb (diff)
downloadportage-6e86c33027196bb8b753d4a5a6a0d84fe3cd0e96.tar.gz
portage-6e86c33027196bb8b753d4a5a6a0d84fe3cd0e96.tar.bz2
portage-6e86c33027196bb8b753d4a5a6a0d84fe3cd0e96.zip
Initial ebuild dev-python/sphinx-click
-rw-r--r--dev-python/sphinx-click/Manifest3
-rw-r--r--dev-python/sphinx-click/metadata.xml13
-rw-r--r--dev-python/sphinx-click/sphinx-click-4.4.0.ebuild29
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/sphinx-click/Manifest b/dev-python/sphinx-click/Manifest
new file mode 100644
index 0000000..9b2de68
--- /dev/null
+++ b/dev-python/sphinx-click/Manifest
@@ -0,0 +1,3 @@
+DIST sphinx-click-4.4.0.tar.gz 25564 BLAKE2B b37a9ad119b4cfd62df4dff112a204d6b3863e4accc846194fdd76aa56e349a56e2289c6a783749d99169cb1552d7dc81add5633a99566a2db426f42edb28352 SHA512 74a1dc653ccf2d424bfbd419291973822e4dea6a73d5a9e6033b48f585d53f2df3400936fa8c875b0fb4259a0f364ddf4d7bc4064e98c7ac47cd4114154f6d60
+EBUILD sphinx-click-4.4.0.ebuild 675 BLAKE2B d8dce442a597f888f84c25ea8ae107a9d162e83623288c514230a46eba56c3ad1b9d694a09422f15bf09cc36d74882ce175f62c23f0c314eb798b9ea24078db1 SHA512 3fd79913c7a524fdf2339dbd4c5d45983b6cf52d8b2dd62c155eeb25e5e5a60f04fa859d1284c329cdc4be4d717ff3b3516ab1e537c9dd21bb60ca346450737d
+MISC metadata.xml 471 BLAKE2B 1f84ef96a9649d87af2b32642ce772793904f7d7df628c6362d95567b524425841da393848f4480ed826b00fb31a74abc577186edd8c085743ca8fc78c9aa1d7 SHA512 7689b4a18ee38cfa09e282d5589e8aa59b337ef944846d5985c48aeef2033c92607392814fdf5c550d71e025c594e008ed7f928c6c16b479c31b61144d42eb3f
diff --git a/dev-python/sphinx-click/metadata.xml b/dev-python/sphinx-click/metadata.xml
new file mode 100644
index 0000000..6fa4517
--- /dev/null
+++ b/dev-python/sphinx-click/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marcin.deranek@slonko.net</email>
+ <name>Marcin Deranek</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/click-contrib/sphinx-click/issues</bugs-to>
+ <remote-id type="github">click-contrib/sphinx-click</remote-id>
+ <remote-id type="pypi">sphinx-click</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinx-click/sphinx-click-4.4.0.ebuild b/dev-python/sphinx-click/sphinx-click-4.4.0.ebuild
new file mode 100644
index 0000000..95104e9
--- /dev/null
+++ b/dev-python/sphinx-click/sphinx-click-4.4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+PYPI_NO_NORMALIZE=1
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx plugin to automatically document click-based applications"
+HOMEPAGE="
+ https://github.com/click-contrib/sphinx-click/
+ https://pypi.org/project/sphinx-click/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/sphinx-2.0[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+"
+BDEPEND=">=dev-python/pbr-2.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs --no-autodoc